hdu 2870 Largest Submatrix (DP)

Largest Submatrix

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1534    Accepted Submission(s): 735


Problem Description
Now here is a matrix with letter 'a','b','c','w','x','y','z' and you can change 'w' to 'a' or 'b', change 'x' to 'b' or 'c', change 'y' to 'a' or 'c', and change 'z' to 'a', 'b' or 'c'. After you changed it, what's the largest submatrix with the same letters you can make?
 

Input
The input contains multiple test cases. Each test case begins with m and n (1 ≤ m, n ≤ 1000) on line. Then come the elements of a matrix in row-major order on m lines each with n letters. The input ends once EOF is met.
 

Output
For each test case, output one line containing the number of elements of the largest submatrix of all same letters.
 

Sample Input
  
  
2 4 abcw wxyz
 

Sample Output
  
  
3
 


又是一个悲伤的故事,做了一上午抓狂,其实就是和1505和1506一样,这题枚举一下a,b,c,就行了,不知为什么酒一直wa,看别人的题解,没有用我这种方法的,都是记一下最左边大于等于它的位置,和右边大于等于它的位置,和我的方法在原理上是一样的,我是记左边大于等于它的位置,右边大于等于它的位置,debug了半天才发现把m打成了n。


代码:

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
using namespace std;
const int maxn=1000+100;
char s[maxn][maxn];
int a[maxn][maxn];
int dpl[maxn],dpr[maxn];
int n,m;
int ans;
void solve(char c,char w,char x,char y)
{
    for(int i=1;i<=n;i++)
    {
        a[i][0]=a[i][m+1]=-1;
        for(int j=1;j<=m;j++)
        {
            if(s[i][j]==c||s[i][j]==w||s[i][j]==x||s[i][j]==y)
            {
                if(i>1)
                a[i][j]=a[i-1][j]+1;
                else
                {
                    a[i][j]=1;
                }
            }
            else
            {
                a[i][j]=0;
            }
        }
       int temp;
       memset(dpl,0,sizeof(dpl));
       memset(dpr,0,sizeof(dpr));
       dpl[1]=1;
       dpr[m]=1;
       for(int j=2;j<=m;j++)
       {
           int k;
           dpl[j]=1;
           if(a[i][j])
           {
               k=j;
               while(a[i][j]<=a[i][k-1])
               {
                   dpl[j]+=dpl[k-1];
                   k-=dpl[k-1];
               }
               // while(a[i][dpl[j]-1]>=a[i][j])
               //  dpl[j]=dpl[dpl[j]-1];
           }
       }
       for(int j=m-1;j>=1;j--)
       {
           int k;
           dpr[j]=1;
           if(a[i][j])
           {
               k=j;
               while(a[i][j]<=a[i][k+1])
               {
                   dpr[j]+=dpr[k+1];
                   k=k+dpr[k+1];
               }
               // while(a[i][dpr[j]+1]>=a[i][j])
               //   dpr[j]=dpr[dpr[j]+1];
           }
       }
       for(int j=1;j<=m;j++)
       {
           if(a[i][j])
           {
           temp=a[i][j]*(dpr[j]+dpl[j]-1);
          // temp=a[i][j]*(dpr[j]-dpl[j]+1);
           if(ans<temp)
           ans=temp;
           }
       }
    }
}

int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        for(int i=1;i<=n;i++)
        {
            scanf("%s",s[i]+1);
        }
        ans=0;
        solve('a','w','y','z');
        solve('b','w','x','z');
        solve('c','x','y','z');
        printf("%d\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值