poj 2001 Shortest Prefixes

Shortest Prefixes
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 14336 Accepted: 6184

Description

A prefix of a string is a substring starting at the beginning of the given string. The prefixes of "carbon" are: "c", "ca", "car", "carb", "carbo", and "carbon". Note that the empty string is not considered a prefix in this problem, but every non-empty string is considered to be a prefix of itself. In everyday language, we tend to abbreviate words by prefixes. For example, "carbohydrate" is commonly abbreviated by "carb". In this problem, given a set of words, you will find for each word the shortest prefix that uniquely identifies the word it represents. 

In the sample input below, "carbohydrate" can be abbreviated to "carboh", but it cannot be abbreviated to "carbo" (or anything shorter) because there are other words in the list that begin with "carbo". 

An exact match will override a prefix match. For example, the prefix "car" matches the given word "car" exactly. Therefore, it is understood without ambiguity that "car" is an abbreviation for "car" , not for "carriage" or any of the other words in the list that begins with "car". 

Input

The input contains at least two, but no more than 1000 lines. Each line contains one word consisting of 1 to 20 lower case letters.

Output

The output contains the same number of lines as the input. Each line of the output contains the word from the corresponding line of the input, followed by one blank space, and the shortest prefix that uniquely (without ambiguity) identifies this word.

Sample Input

carbohydrate
cart
carburetor
caramel
caribou
carbonic
cartilage
carbon
carriage
carton
car
carbonate

Sample Output

carbohydrate carboh
cart cart
carburetor carbu
caramel cara
caribou cari
carbonic carboni
cartilage carti
carbon carbon
carriage carr
carton carto
car car

carbonate carbona

字典树入门题!

题意:

输出在字典中有相同的前缀+1个字符来唯一识别这个单词,该单词在字典中是前缀,则输出它。

代码:

/*
1、对每个结点开一个字母集大小的数组,对应的下标是儿子所表示的字母,
内容则是这个儿子对应在大数组上的位置,即标号;
*/
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int Max=30;
const int maxn=11000;
typedef struct node
{
    int count;// 该节点前缀 出现的次数
    struct node *next[Max];//该节点的后续节点
}node;
char s[1020][25];
node a[maxn];
int cur=0;
int n=0;
node *root;
//初始化一个节点。nCount计数为1, next都为null
node *creat()
{
    node *tmp=&a[cur++];
    tmp->count=1;
    for(int i=0;i<Max;i++)
    tmp->next[i]=NULL;
    return tmp;
}
void insert(char *str)
{
    int temp,len;
    node *p;
    p=root;
    len=strlen(str);
    for(int i=0;i<len;i++)
    {
        temp=str[i]-'a';
        if(p->next[temp]!=NULL)
        {
            p=p->next[temp];
            p->count++;
        }
        else
        {
            p->next[temp]=creat();
            p=p->next[temp];
        }
    }
}
void find(char *str)
{
    int len,temp;
    node *p;
    p=root;
    len=strlen(str);
    for(int i=0;i<len;i++)
    {
        temp=str[i]-'a';
        p=p->next[temp];
        if(p->count>1)
        printf("%c",str[i]);
        else
        {
           printf("%c",str[i]);//多输出了一个
           return;
        }
    }
}
int main()
{
     root=creat();//根节点
    while(~scanf("%s",s[n]))
    {
        insert(s[n]);//建树
        n++;
    }
    for(int i=0;i<n;i++)
    {
        printf("%s ",s[i]);
        find(s[i]);//查询
        printf("\n");
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值