POJ - 2001 -- Shortest Prefixes【字典树】

Shortest Prefixes
Description

A prefix of a string is a substring starting at the beginning of the given string. The prefixes of “carbon” are: “c”, “ca”, “car”, “carb”, “carbo”, and “carbon”. Note that the empty string is not considered a prefix in this problem, but every non-empty string is considered to be a prefix of itself. In everyday language, we tend to abbreviate words by prefixes. For example, “carbohydrate” is commonly abbreviated by “carb”. In this problem, given a set of words, you will find for each word the shortest prefix that uniquely identifies the word it represents.

In the sample input below, “carbohydrate” can be abbreviated to “carboh”, but it cannot be abbreviated to “carbo” (or anything shorter) because there are other words in the list that begin with “carbo”.

An exact match will override a prefix match. For example, the prefix “car” matches the given word “car” exactly. Therefore, it is understood without ambiguity that “car” is an abbreviation for “car” , not for “carriage” or any of the other words in the list that begins with “car”.

Input

The input contains at least two, but no more than 1000 lines. Each line contains one word consisting of 1 to 20 lower case letters.

Output

The output contains the same number of lines as the input. Each line of the output contains the word from the corresponding line of the input, followed by one blank space, and the shortest prefix that uniquely (without ambiguity) identifies this word.

Sample Input

carbohydrate
cart
carburetor
caramel
caribou
carbonic
cartilage
carbon
carriage
carton
car
carbonate

Sample Output

carbohydrate carboh
cart cart
carburetor carbu
caramel cara
caribou cari
carbonic carboni
cartilage carti
carbon carbon
carriage carr
carton carto
car car
carbonate carbona

题意

在字典中找出最短的唯一前缀,如果没有就打印整个字符串。

思路

用一个num数组记录每个结点的编号,在遍历每个字符串的过程中,如果出现num[i] == 1时, 则代表最短前缀,然后返回当前索引(或者是边遍历边打印)。

AC代码
/**
	时间复杂度为O(len*n)的算法。 
**/
#include<cstdio>
#include<cstring>
#include<iostream>
using namespace std;
const int maxn = 2e4 + 5;
int tree[maxn][26];//i号结点有没有j字符的边。如果有存的是这个端点的编号 
int num[maxn];//表示出现过没有,并且出现过几次 
int k = 1;//从一号结点开始编号 
char str[maxn][26];
void insert(char *w, int len){
	int u = 0;
	for (int i = 0; i < len; ++i){
		int v = w[i] - 'a';
		if (!tree[u][v]){
			tree[u][v] = k++;
		}
		u = tree[u][v];
		num[u]++;
	}
}
int query(char *w, int len){
	int u = 0;
	for (int i = 0; i < len; ++i){
		int v = w[i] - 'a';
		u = tree[u][v];
		if (num[u] == 1) return i;
	}
	return len - 1;
}
void solve(){
	int cnt = 0;
	while (scanf("%s", str[cnt]) != EOF){
		insert(str[cnt], strlen(str[cnt]));
		cnt++;
	}
	for (int i = 0; i < cnt; ++i){
		printf("%s ", str[i]);
		int pos = query(str[i], strlen(str[i]));
		for (int j = 0; j <= pos; ++j){
			printf("%c", str[i][j]);
		}
		puts("");
	}
}
int main(){
	solve();
	return 0;
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

星空皓月

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值