(hdu step 4.1.1)Can you solve this equation?(使用二分法来求解方程组的解)

题目:

Can you solve this equation?

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 915 Accepted Submission(s): 436
 
Problem Description
Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;
Now please try your lucky.
 
Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);
 
Output

            For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.
 
Sample Input
2
100
-4
 
Sample Output
1.6152
No solution!
 
Author
Redow
 
 
Recommend
lcy


题目分析:

               简单题。是用二分法来求方程组的解。使用二分法来求方程组的解的前提是该方程具有单调性。


代码如下:

/*
 * a.cpp
 *
 *  Created on: 2015年2月16日
 *      Author: Administrator
 */

#include <iostream>
#include <cstdio>
#include <cmath>



using namespace std;

const double delta = 1e-6;//1e10表示10^10

double function(double x){
	return 8*pow(x,4.0) + 7*pow(x,3) + 2*pow(x,2) + 3*x + 6;
}



/**
 * 用二分法来求解方程组的解
 * y:方程组右边的数
 */
double work(double y){
	double mid;
	double left = 0;
	double right = 100;

	while(right - left > delta){//如果右边的索引还比左边的索引大
		mid = (left+right)/2;//计算中间值

		if(function(mid) < y){//如果y大于中间值...注意这种写法
			left = mid+(1e-7);//移动左边的索引。需要注意的是这里使用的偏移量应该比上面的小
		}else{//否则
			right = mid-(1e-7);//移动右边的索引
		}
	}

	return (left+right)/2;//返回最后的值
}




int main(){
	int t;
	scanf("%d",&t);
	while(t--){
		double y;
//		scanf("%d",&y);

		cin >> y;

		if(function(0) <= y && y <= function(100)){
			printf("%.4lf\n",work(y));
//			printf("%.4lf\n",find(y));
		}else{
			printf("No solution!\n");
		}
	}

	return 0;
}








评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

帅气的东哥

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值