【POJ】Radar Installation题解

原题链接

Description

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d.

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.

在这里插入图片描述

Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.

The input is terminated by a line containing pair of zeros

Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. “-1” installation means no solution for that case.

Sample Input

3 2
1 2
-3 1
2 1

1 2
0 2

0 0

Sample Output

Case 1: 2
Case 2: 1

解题思路
  1. 如果海岛的y坐标大于雷达的半径,那么一定无解。
  2. 如果有解,那么将每个海岛的左右极限求出来,然后按照左端点从小到大排序,依次遍历,如果当前海岛的左端点在当前雷达的右端点之前,那么说明该雷达可以检测到该海岛,并且雷达右端点要更新为当前海岛的右端点和当前雷达的右端点的最小值;如果当前海岛的左端点超过当前雷达的右端点,那么该雷达肯定检测不到该海岛,那么就要加一个雷达,并且右端点为该海岛的右端点。即:
        for(int i = 1; i < n; i++)
        {
            if( a[i].first <= r)
            {
                r = min(r, a[i].second);
                continue;
            }
            else
            {
                sum++;
                r = a[i].second;
            }
        }
坑点
  1. 输出的时候忘了格式化了,每个输出都写成了Case 1:
  2. 如果无解,输出-1的时候也得写Case
  3. 如果if( a[i].first <= r),忘记更新右端点了,需要将右端点更新为海岛和雷达的最小值。
  4. 左右端点要用double,因为开方之后可能为小数。
AC代码
#include <iostream>
#include <algorithm>
#include <cmath>
#include <cstdio>
using namespace std;
int n, d, x, y;
typedef pair <double, double> p;
p a[1005];
bool cmp(p a, p b)
{
    return a.first < b.first;
}
int main(void)
{
    int t = 0;
    while(cin >> n >> d)
    {
        if(n == 0 && d == 0)
            break;
        t++;
        int flag = 1;
        for(int i = 0; i < n; i++)
        {
            cin >> x >> y;
            if(y > d)
            {
                flag = 0;
            }
            a[i].first = x - sqrt(d  * d - y * y);
            a[i].second = x + sqrt(d  * d - y * y);
        }
        if(flag == 0)
        {
            printf("Case %d: -1\n", t);
            continue;
        }
        sort(a, a + n, cmp);
        int sum = 1;
        double r = a[0].second;
        for(int i = 1; i < n; i++)
        {
            if( a[i].first <= r)
            {
                r = min(r, a[i].second);
                continue;
            }
            else
            {
                sum++;
                r = a[i].second;
            }
        }
       printf("Case %d: %d\n", t, sum);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值