Red and Black
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 7735 Accepted Submission(s): 4853
Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.
Write a program to count the number of black tiles which he can reach by repeating the moves described above.
Write a program to count the number of black tiles which he can reach by repeating the moves described above.
Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.
There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.
'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.
'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
Sample Input
6 9 ....#. .....# ...... ...... ...... ...... ...... #@...# .#..#. 11 9 .#......... .#.#######. .#.#.....#. .#.#.###.#. .#.#..@#.#. .#.#####.#. .#.......#. .#########. ........... 11 6 ..#..#..#.. ..#..#..#.. ..#..#..### ..#..#..#@. ..#..#..#.. ..#..#..#.. 7 7 ..#.#.. ..#.#.. ###.### ...@... ###.### ..#.#.. ..#.#.. 0 0
Sample Output
45 59 6 13
#include<stdio.h>
#include<string.h>
int h,w,ans;
char s[24][24];
int dir[4][2]= {-1,0,0,1,1,0,0,-1};
void dfs(int i,int j)
{
if(i<0||i>=h||j<0||j>=w||s[i][j]=='#') return;
ans++;
s[i][j]='#';
for(int k=0; k<4; k++)
dfs(i+dir[k][0],j+dir[k][1]);
}
int main()
{
int i,j;
while(scanf("%d%d",&w,&h),w!=0)
{
ans=0;
memset(s,0,sizeof(s));
for(i=0; i<h; i++)
scanf("%s",s[i]);
for(i=0; i<h; i++)
for(j=0; j<w; j++)
if(s[i][j]=='@')
dfs(i,j);
printf("%d\n",ans);
}
return 0;
}