8.3 D - 这是水题4

                                       D - 这是水题4


In the planet w-503 of galaxy cgb, there is a kind of intelligent creature named QS. QScommunicate with each other via networks. If two QS want to get connected, they need to buy two network adapters (one for each QS) and a segment of network cable. Please be advised that ONE NETWORK ADAPTER CAN ONLY BE USED IN A SINGLE CONNECTION.(ie. if a QS want to setup four connections, it needs to buy four adapters). In the procedure of communication, a QS broadcasts its message to all the QS it is connected with, the group of QS who receive the message broadcast the message to all the QS they connected with, the procedure repeats until all the QS's have received the message.

A sample is shown below:


A sample QS network, and QS A want to send a message.

Step 1. QS A sends message to QS B and QS C;

Step 2. QS B sends message to QS A ; QS C sends message to QS A and QS D;

Step 3. the procedure terminates because all the QS received the message.

Each QS has its favorate brand of network adapters and always buys the brand in all of its connections. Also the distance between QS vary. Given the price of each QS's favorate brand of network adapters and the price of cable between each pair of QS, your task is to write a program to determine the minimum cost to setup a QS network.


Input

The 1st line of the input contains an integer t which indicates the number of data sets.

From the second line there are t data sets.

In a single data set,the 1st line contains an interger n which indicates the number of QS.

The 2nd line contains n integers, indicating the price of each QS's favorate network adapter.

In the 3rd line to the n+2th line contain a matrix indicating the price of cable between ecah pair of QS.

Constrains:

all the integers in the input are non-negative and not more than 1000.


Output

for each data set,output the minimum cost in a line. NO extra empty lines needed.

Sample Input

1
3
10 20 30
0 100 200
100 0 300
200 300 0


Sample Output

370



题意:有n个外星人想相互联系,并且每个外星人都有自己喜欢用的联系工具,每两个相互联系的外星人还需要一根有价格的网线,求出所有外星人直接或者间接能够联系所购买的联系工具和网线的最少价格。注意:比如说1号外星人和3号外星人和4号外星人能够联系,需要买2个1号外星人喜欢的联系工具.1个3号外星人喜欢的联系工具和1个4号外星人的联系工具。

先输入一个数字T,表示T组数据,然后输入数字n,接下来n个数据表示每个外星人所喜欢的联系工具的价格,

接下来一个n*n大小的矩阵,表示每两个外星人之间网线的价格。



#include<stdio.h>
#include<string.h>
int a[2000][2000],book[2000],d[2000],s[2000];
int main()
{
	int i,j,k,m,n,c,t;
	int max=1e9,min;
	int t1,sum;
	while(scanf("%d",&t)!=EOF)
	{
		while(t--)
		{
			scanf("%d",&n);
			memset(a,0,sizeof(a));
			memset(d,0,sizeof(d));
			memset(s,0,sizeof(s));
			memset(book,0,sizeof(book));
			m=0;
			for(i=0;i<=n;i++)
			{
				for(j=0;j<=n;j++)
				{
					if(i==j)
					{
						a[i][j]=0;
					}
					else
					{
						a[i][j]=max;
					}
				}
			}//初始化数据

			
			
			for(i=1;i<=n;i++)
			{
				scanf("%d",&s[i]);//存储每个外星人喜欢的联系工具的价格
			}
			for(i=1;i<=n;i++)
			{
				for(j=1;j<=n;j++)
				{
					scanf("%d",&a[i][j]);
					if(i!=j)
					{
						a[i][j]+=s[i]+s[j];//存储网线价格时同时将联系工具价格一起存入
					}
				}
			}
			
			for(i=1;i<=n;i++)
			{
				d[i]=a[1][i];
			}
			c=0;
			book[1]=1;
			c++;
			sum=0;
			while(c<n)//Prim算法计算
			{
				min=max;
				for(i=1;i<=n;i++)
				{
					if(book[i]==0&&d[i]<min)
					{
						min=d[i];
						j=i;
					}
				}
				c++;
				sum+=d[j];
				book[j]=1;
				for(i=1;i<=n;i++)
				{
					if(book[i]==0&&a[j][i]<d[i])
					{
						d[i]=a[j][i];
					}
				}
			}
			printf("%d\n",sum);
		}
	}
	return 0;
}



 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值