hdu1002 A + B Problem II(大数相加)

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 189701    Accepted Submission(s): 36249


Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

Sample Input
  
  
2 1 2 112233445566778899 998877665544332211
 

Sample Output
  
  
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110
 
#include<stdio.h>
#include<string.h>
char s1[1004],s2[1004];
int a[1004],b[1004];
int main()
{
    int t,u,i,j,c;
    scanf("%d",&t);
    for(u=1;u<=t;u++)
    {
        memset(a,0,sizeof(a));
        memset(b,0,sizeof(b));
        scanf("%s%s",s1,s2);
        if(u!=1) printf("\n");
        printf("Case %d:\n%s + %s = ",u,s1,s2);
        j=0;
        for(i=strlen(s1)-1;i>=0;i--)
            a[j++]=s1[i]-'0';
        j=0;
        for(i=strlen(s2)-1;i>=0;i--)
            b[j++]=s2[i]-'0';
        i=c=0;
        while(i<strlen(s1)||i<strlen(s2)||c)
        {
            a[i]+=b[i]+c;
            c=0;
            if(a[i]>9)
            {
                a[i]-=10;
                c=1;
            }
            i++;
        }
        for(--i;i>=0;i--)
            printf("%d",a[i]);
        printf("\n");
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值