PAT -- 甲级1008(1008 Elevator)

1008 Elevator (20 分)

The highest building in our city has only one elevator. A request list is made up with NNN positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input Specification:

Each input file contains one test case. Each case contains a positive integer NNN, followed by NNN positive numbers. All the numbers in the input are less than 100.

Output Specification:

For each test case, print the total time on a single line.

Sample Input:

3 2 3 1

Sample Output:

41

给一个数n后面跟着n个数,表示电梯的层数,刚开始从0层开始,上升1层用6秒,下降一层用4秒,停一层用5秒,问按照这个顺序执行需要用几秒,电梯最后不必返回0层

思路:模拟

Code

#include<bits/stdc++.h>

using namespace std;

int val[105],n;

int main() {
	cin >> n;
	for (int i = 0; i < n; i++) {
		cin >> val[i];
	}
	int res = val[0] * 6, tmp;
	for (int i = 1; i < n; i++) {
		tmp = val[i] - val[i - 1];
		if (tmp > 0) {
			res += tmp * 6;
		} else {
			res -= tmp * 4;
		}
	}
	cout << res + n * 5 << endl;
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

小胡同的诗

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值