【PAT甲级】1008 Elevator (20 分)

1008 Elevator

题目描述:

The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.

Output Specification:

For each test case, print the total time on a single line.

Sample Input:

3 2 3 1

Sample Output:

41

思路

本题比较简单,注意题目所说的要求就可以了,输入的数字,第一个表示有多少个电梯请求,之后是每一个请求

遍历时候,只要记录一下当前电梯位置即可

代码
#include<stdio.h>

int main()
{
    int N;
    scanf("%d",&N);
    int *list=new int[N];
    for(int i=0;i<N;i++)
    {
        scanf("%d",&list[i]);
    }
    int cur=0,time=0;
    for(int i=0;i<N;i++)
    {
        if(list[i]>cur)
        {
            time+=(list[i]-cur)*6;
        }
        else
        {
            time+=(cur-list[i])*4;
        }
        cur=list[i];
    }
    time+=5*N;
    printf("%d\n",time);
    return 0;
}

git仓库:Elevator

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值