(题目)(威尔逊+逆元+大数乘求模)Fansblog

时间限制: 1 Sec 内存限制: 128 MB
题目描述
Farmer John keeps a website called ‘FansBlog’ .Everyday , there are many people visited this blog.One day, he find the visits has reached P , which is a prime number.He thinks it is a interesting fact.And he remembers that the visits had reached another prime number.He try to find out the largest prime number Q ( Q < P ) ,and get the answer of Q! Module P.But he is too busy to find out the answer. So he ask you for help. ( Q! is the product of all positive integers less than or equal to n: n! = n * (n-1) * (n-2) * (n-3) *… * 3 * 2 * 1 . For example, 4! = 4 * 3 * 2 * 1 = 24 )

输入
First line contains an number T(1<=T<=10) indicating the number of testcases.
Then T line follows, each contains a positive prime number P (1e9≤p≤1e14)

输出
For each testcase, output an integer representing the factorial of Q modulo P.

样例输入
1
1000000007

样例输出
328400734

#include <bits/stdc++.h>
using namespace std;
typedef long long ll;
ll mul(ll a,ll b,ll mod)
{
    a%=mod;
    b%=mod;
    ll res=0;
    while(b)
    {
        if(b&1)
        {
            res+=a;
            if(res>=mod)
                res-=mod;
        }
        b>>=1;
        a<<=1;
        if(a>=mod)
            a-=mod;
    }
    return res;
}
ll quickPow(ll a,ll b,ll m)
{
    ll res=1;
    while(b)
    {
        if(b&1)
            res=mul(res,a,m);
        a=mul(a,a,m);
        b>>=1;
    }
    return res;
}
int main()
{
    int T;
    ll ans;
    ll Q,P;
    bool flag;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%lld",&P);
        Q=P;
        while(1)
        {
            ans=1;
            Q--;
            flag=true;
            for(ll i=2; i<=sqrt(Q); i++)
            {
                if(Q%i==0)
                {
                    flag=false;
                    break;
                }
            }
            if(flag)
            {
                break;
            }
        }
        Q++;
        while(1)
        {
            if(Q==P-1)
                break;
            else
                ans=mul(ans,Q,P);
            Q++;
        }
        printf("%lld\n",quickPow(ans,P-2,P)%P);
    }
    return 0;
}
 
/**************************************************************
    Problem: 12969
    User: reserve2018058
    Language: C++
    Result: 正确
    Time:818 ms
    Memory:2036 kb
****************************************************************/
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值