hdu4864 Task

Task

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 9885    Accepted Submission(s): 2398


Problem Description
Today the company has m tasks to complete. The ith task need xi minutes to complete. Meanwhile, this task has a difficulty level yi. The machine whose level below this task’s level yi cannot complete this task. If the company completes this task, they will get (500*xi+2*yi) dollars.
The company has n machines. Each machine has a maximum working time and a level. If the time for the task is more than the maximum working time of the machine, the machine can not complete this task. Each machine can only complete a task one day. Each task can only be completed by one machine.
The company hopes to maximize the number of the tasks which they can complete today. If there are multiple solutions, they hopes to make the money maximum.
 

Input
The input contains several test cases. 
The first line contains two integers N and M. N is the number of the machines.M is the number of tasks(1 < =N <= 100000,1<=M<=100000).
The following N lines each contains two integers xi(0<xi<1440),yi(0=<yi<=100).xi is the maximum time the machine can work.yi is the level of the machine.
The following M lines each contains two integers xi(0<xi<1440),yi(0=<yi<=100).xi is the time we need to complete the task.yi is the level of the task.
 

Output
For each test case, output two integers, the maximum number of the tasks which the company can complete today and the money they will get.
 

Sample Input
 
 
1 2100 3100 2100 1
 

Sample Output
 
 
1 50004
 

Author
/*
注意此题没有天数限制,尽管每台机器一天只能运行一个任务,且运行时间有限 
首先考虑获得的报酬公式:500*costtime+2*dif,所以dif可以当做次要因素,主要因素是时间。
所以对任务排序原则是 需要机器的时间大->小,需要时间相同的话难度等级大->小排序。
接下来就是枚举,将所有满足机器运行时间>=任务时间的加入数组,然后选满足完成任务的机器里等级最小去完成 
这样的巧妙之处在于后面的加进来的任务必定可以被先前加进来的机器所完成。
因为任务是按时间降序排列的。那么这道题就得到了完美的解决。
*/ 

#include<cstdio>  
#include<iostream>  
#include<cstring>  
#include<algorithm>  
using namespace std;  
  
const int maxn=100000+10;  
int level[100+10];  
int n,m,sum;  
__int64 ans;  
  
struct node{  
    int costtime;  //消耗时间 
    int dif;  //技术难度 
}machine[maxn],task[maxn];  
  
  
bool cmp(node a,node b)  
{  //先将时间降序排列,时间相同,技术难度高的优先。 
   if(a.costtime==b.costtime) 
   return a.dif>b.dif;  
   else
   return a.costtime>b.costtime;  
}  
  
void read_data()  //读数据并排序 
{  
    for(int i=1;i<=n;i++)  
        scanf("%d%d",&machine[i].costtime,&machine[i].dif);  
    for(int i=1;i<=m;i++)  
        scanf("%d%d",&task[i].costtime,&task[i].dif);  
    sort(task+1,task+1+m,cmp);  
    sort(machine+1,machine+1+n,cmp);  
}  
  
int main()  
{  
    while(~scanf("%d%d",&n,&m))  //n台机器,m个任务 
    {  
        ans=sum=0;  
        read_data();  
        memset(level,0,sizeof(level)); 
        
        for(int i=1,j=1;i<=m;i++)  //i代表第几个任务,j代表第几台机器 
        {  
            while(j<=n&&machine[j].costtime>=task[i].costtime)  //要求机器的可工作时间大于任务的需要时间 
            {  
                level[machine[j].dif]++; //每种可处理难度机器的数量 
                j++;  
            }  
            for(int k=task[i].dif;k<=100;k++) //难度向上兼容 
            {  
                if(level[k])  // 如果存在可以处理的机器。 
                {  
                    level[k]--;  
                    ans=ans+500*task[i].costtime+2*task[i].dif;  
                    sum++;  
                    break;  //跳出K的循环,回到i的循环 
                }  
            }  
        }  
        printf("%d %I64d\n",sum,ans);  
    }  
    return 0;  
}  

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值