hdu2845 Beans 二维的最大不连续子序列和

Beans

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5481    Accepted Submission(s): 2501


Problem Description
Bean-eating is an interesting game, everyone owns an M*N matrix, which is filled with different qualities beans. Meantime, there is only one bean in any 1*1 grid. Now you want to eat the beans and collect the qualities, but everyone must obey by the following rules: if you eat the bean at the coordinate(x, y), you can’t eat the beans anyway at the coordinates listed (if exiting): (x, y-1), (x, y+1), and the both rows whose abscissas are x-1 and x+1.


Now, how much qualities can you eat and then get ?
 

Input
There are a few cases. In each case, there are two integer M (row number) and N (column number). The next M lines each contain N integers, representing the qualities of the beans. We can make sure that the quality of bean isn't beyond 1000, and 1<=M*N<=200000.
 

Output
For each case, you just output the MAX qualities you can eat and then get.
 

Sample Input
 
 
4 611 0 7 5 13 978 4 81 6 22 41 40 9 34 16 1011 22 0 33 39 6
 

Sample Output
 
 
242
 

Source
/*
对于一行来说,相邻的数不可同时取,
容易得到状态转移方程:sum[i] = max (sum[i-2]+sum[i], sum[i-1])(
i>=2,注意i从1开始,i-2=0时不存在sum[i-2]相当于只取sum[i]),
初始时sum[0] = 0, sum[i]就是第i个数
而对于一列来说,显然的也是相邻的不能取,所以对每一行处理完后再用每行得到结果组成一列,进行同样处理即可得出答案
*/ 
#include <iostream>  
using namespace std;  
#define M 200005  
  
int a[M], b[M];  
  
int main()  
{  
	//二维的最大不连续子序列和 
    int m, n, i, j;  
    while (~scanf ("%d%d", &m, &n))  
    {  
        for (i = 1; i <= m; i++)  
        {  
            for (j = 1; j <= n; j++)  
                scanf ("%d", &b[j]);  
            for (j = 2; j <= n; j++)  
                b[j] = max (b[j-2]+b[j], b[j-1]);  
            a[i] = b[n];  
        }  
        for (i = 2; i <= m; i++)  
            a[i] = max (a[i]+a[i-2], a[i-1]);  
            
        printf ("%d\n", a[m]);  
    }  
    return 0;  
} 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值