Beans HDU - 2845 (dp)

题目链接:点我


 Bean-eating is an interesting game, everyone owns an M*N matrix, which is filled with different qualities beans. Meantime, there is only one bean in any 1*1 grid. Now you want to eat the beans and collect the qualities, but everyone must obey by the following rules: if you eat the bean at the coordinate(x, y), you can’t eat the beans anyway at the coordinates listed (if exiting): (x, y-1), (x, y+1), and the both rows whose abscissas are x-1 and x+1.


Now, how much qualities can you eat and then get ? 

Input
There are a few cases. In each case, there are two integer M (row number) and N (column number). The next M lines each contain N integers, representing the qualities of the beans. We can make sure that the quality of bean isn’t beyond 1000, and 1<=M*N<=200000.
Output
For each case, you just output the MAX qualities you can eat and then get.
Sample Input

4 6
11 0 7 5 13 9
78 4 81 6 22 4
1 40 9 34 16 10
11 22 0 33 39 6

Sample Output

242

题意:

一个 n * m的矩阵,矩阵的每个点有不同的值,你每次可以选取坐标为(x, y) 的矩阵但是选取了这个点后你不能选取它左右相邻的点,也不能选取上一行和下一行,问最大值是多少.

思路:

动态规划, 对于一行来说,相邻的数不可同时取,容易得到状态转移方程:
dp[i]=max(dp[i-2]+a[i],dp[i-1]); 每一行和每一列进行相同的处理.

代码:

#include<cstdio>
#include<algorithm>
#include<cmath>
#include<iostream>
using namespace std;

const int maxn = 200000+10;
int dpx[maxn],dpy[maxn];

int main(){
    int n,m;
    while(scanf("%d %d", &n, &m) != EOF){
        for(int i = 2;i<=n+1;++i){
            for(int  j = 2;j<=m+1;++j){
                int s;
                scanf("%d", &s);
            dpy[j]=max(dpy[j-1],dpy[j-2]+s);
            }
            dpx[i]=max(dpx[i-1],dpx[i-2]+dpy[m+1]);
        }
        printf("%d\n",dpx[n+1]);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
spring-beans-5.3.10.release.jar是Spring框架的一个核心模块之一。Spring框架是一个开源的Java应用程序开发框架,用于简化企业级应用程序的开发。spring-beans模块提供了容器和配置文件等机制,用于管理和组织JavaBean对象。 在Spring框架中,JavaBean是一种符合特定规范的类,它用于封装数据和提供业务逻辑。Spring框架的思想是通过将应用程序的配置信息和业务逻辑与具体实现解耦,从而提高应用程序的可维护性和可测试性。 spring-beans模块的主要功能包括: 1. 容器:spring-beans模块提供了一个容器,用于管理和组织JavaBean对象。容器负责创建、销毁和管理对象的生命周期,并提供依赖注入等功能,使得对象之间的协作更加灵活和可配置。 2. 配置文件:spring-beans模块支持使用XML、注解或Java代码等方式来配置应用程序的各个组件,包括JavaBean的定义、依赖关系的声明以及其他配置信息。配置文件使得应用程序的配置更加直观和可维护。 3. 依赖注入:spring-beans模块通过依赖注入的方式,将对象之间的依赖关系从代码中分离出来,并由容器进行管理。这使得对象之间的耦合度降低,同时也提高了代码的可测试性和可重用性。 4. AOP(面向切面编程):spring-beans模块支持AOP,可以通过配置文件或注解的方式来声明横切逻辑,并将其应用到目标对象的方法上。AOP可以实现事务管理、日志记录、性能监控等功能,提高应用程序的扩展性和可维护性。 5. 事件机制:spring-beans模块提供了一个事件机制,用于在对象之间传递消息。应用程序中的某个事件发生时,容器会将该事件通知给所有注册了对应监听器的对象。事件机制可以实现解耦和、松散耦合的软件设计。 总之,spring-beans-5.3.10.release.jar是Spring框架的一个核心模块,提供了容器、配置文件、依赖注入、AOP和事件机制等功能,用于简化企业级Java应用程序的开发。它的存在使得应用程序的开发更加简单、灵活和可维护。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值