hdu1250 Hat's Fibonacci

Hat's Fibonacci

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12633    Accepted Submission(s): 4241


Problem Description
A Fibonacci sequence is calculated by adding the previous two members the sequence, with the first two members being both 1.
F(1) = 1, F(2) = 1, F(3) = 1,F(4) = 1, F(n>4) = F(n - 1) + F(n-2) + F(n-3) + F(n-4)
Your task is to take a number as input, and print that Fibonacci number.
 

Input
Each line will contain an integers. Process to end of file.
 

Output
For each case, output the result in a line.
 

Sample Input
 
 
100
 

Sample Output
 
 
4203968145672990846840663646 Note: No generated Fibonacci number in excess of 2005 digits will be in the test data, ie. F(20) = 66526 has 5 digits.
 

Author
//题目中说答案中的结果不会超过2005位数字,而我一个int 存了8位,所以可以确定数组的第二维
//最多开个260 260*8=2080>2005就行,而1维嘛,10的2006次方大约等于2的7000多次方,所以开个8000足够; 
#include<stdio.h>
int i,j,n;
int ans[8000][255]={{0}};//先打表再查表 ans[个数][这个数的每一位的值] 
void fun()
{
	for(i=1;i<5;i++)
	ans[i][1]=1;//注意,这里为了方便,二维都是从1开始的 
	
	for(i=5;i<8000;i++)
	for(j=1;j<255;j++)
	{
		ans[i][j]+=ans[i-1][j]+ans[i-2][j]+ans[i-3][j]+ans[i-4][j];
    	ans[i][j+1]+=ans[i][j]/100000000;
    	ans[i][j]%=100000000;
	}
}

int main()
{  

	fun();
	while(scanf("%d",&n)!=EOF)
	{
		for(i=254;i>0;i--)//从前往后找到有效值 
			if(ans[n][i])
				break;
		printf("%d",ans[n][i]);//为了不输出前导0,所以这里特别输出 
		i--; 
		for(i;i>0;i--)//继续使用上面循环中的i,并减1 
	 	printf("%.8d",ans[n][i]);
		printf("\n");
	}
	return 0;
} 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值