动态规划:To the Max 最大子矩阵

本文介绍了如何使用动态规划解决1092题——To the Max的问题,包括输出示例、输入样例和预期的输出结果。通过实例解析算法思路,并提供了Java代码实现。
摘要由CSDN通过智能技术生成

[转]http://blog.csdn.net/kongming_acm/article/details/5725917

 

1092: To the Max


ResultTIME LimitMEMORY LimitRun TimesAC TimesJUDGE
3s8192K1256268Standard
Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1 x 1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.

As an example, the maximal sub-rectangle of the array:

0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2

is in the lower left corner:

9 2
-4 1
-1 8

and has a sum of 15.

The input consists of an N x N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N 2 integers separated by whitespace (spaces and newlines). These are the N 2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].

 

Output

Output the sum of the maximal sub-rectangle.

Sample Input

4 0 -2 -7 0 9 2 -6 2 -4 1 -4 1 -1 8 0 -2

Sample Output

15

 


This problem is used for contest: 35 

 

package com.iteye.caoruntao.zoj;

import java.util.Scanner;

/**
 * @author caoruntao
 *
 */
public class ToTheMax {

	private static int a[][];
	private static int n;
	private static int max;
	
	public static void compute(){
		max = 1<<31;
		for(int i=0; i<n; i++){
			int f[] = new int[101];
			for(int j=i; j<n; j++){
				int b = 0;
				for(int k=0; k<n; k++){
					f[k] += a[k][j];
				}
				for(int k=0; k<n; k++){
					if(b > 0){
						b += f[k];
					}
					else{
						b = f[k];
					}
					if(b > max){
						max = b;
					}
				}
			}
		}
		System.out.println(max);
	}
	
	/**
	 * @param args
	 */
	public static void main(String[] args) {
		a = new int[101][101];
		Scanner sc = new Scanner(System.in);
		while(sc.hasNextInt()){
			n = sc.nextInt();
			for(int i=0; i<n; i++){
				for(int j=0; j<n; j++){
					a[i][j] = sc.nextInt();
				}
			}
			compute();
		}
		
	}

}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值