POJ-3279-Fliptile解题思路

POJ-3279-Fliptile解题思路

相关文章(写得真的好好)https://blog.csdn.net/wr132/article/details/45250529

题目
Farmer John knows that an intellectually satisfied cow is a happy cow who will give more milk. He has arranged a brainy activity for cows in which they manipulate an M × N grid (1 ≤ M ≤ 15; 1 ≤ N ≤ 15) of square tiles, each of which is colored black on one side and white on the other side.
As one would guess, when a single white tile is flipped, it changes to black; when a single black tile is flipped, it changes to white. The cows are rewarded when they flip the tiles so that each tile has the white side face up. However, the cows have rather large hooves and when they try to flip a certain tile, they also flip all the adjacent tiles (tiles that share a full edge with the flipped tile). Since the flips are tiring, the cows want to minimize the number of flips they have to make.
Help the cows determine the minimum number of flips required, and the locations to flip to achieve that minimum. If there are multiple ways to achieve the task with the minimum amount of flips, return the one with the least lexicographical ordering in the output when considered as a string. If the task is impossible, print one line with the word “IMPOSSIBLE”.
Input
Line 1: Two space-separated integers: M and N
Lines 2.. M+1: Line i+1 describes the colors (left to right) of row i of the grid with N space-separated integers which are 1 for black and 0 for white
Output
Lines 1.. M: Each line contains N space-separated integers, each specifying how many times to flip that particular location.
Sample Input

4 4
1 0 0 1
0 1 1 0
0 1 1 0
1 0 0 1

Sample Output

0 0 0 0
1 0 0 1
1 0 0 1
0 0 0 0

题目大意:

牛翻转瓷砖,每翻转一块,这块瓷砖的上下左右都会更着翻转,求牛最少翻转多少次可以让瓷砖全是白色,要求输出翻转次数最少的情况下对应的每块瓷砖翻转的次数

/*由题意可知,下一行的翻转一定会影响到上一行,所以,不妨枚举第一行翻转后的所有情况。
此后每一行都为将上一行翻转全为白色而翻转(若本行元素对应的同列的上一行为黑色,
就将这一元素翻转)最后判断最后一行是否为全白即可

代码用到的二进制状态压缩,代码注释中有解释,可参考篇首链接*/
#include <iostream>
#include <cstring>
#include <string>
using namespace std;

int point[20][20];
int num[20][20];
int temp[20][20];
int vis[20][20];
int n,m,cnt;
int ans;
int x1[4] = {0,0,-1,1};
int y1[4] = {-1,1,0,0};

//翻转函数,用取反和异或来实现状态的翻转
void flip(int x,int y)
{
    cnt++;
    num[x][y]=1;
    temp[x][y]=!temp[x][y];
    for(int i = 0;i<4;i++)
    {
        if(x+x1[i]>=0&&y+y1[i]>=0)
        {
            //cout<<temp[x+x1[i]][y+y1[i]]<<endl;
            temp[x+x1[i]][y+y1[i]]^=1;//取反
            //cout<<temp[x+x1[i]][y+y1[i]]<<endl;
        }
    }

}

bool menum(int k)
{
    memcpy(temp,point,sizeof(temp));
    for(int i=0;i<m;i++)
    {
        if(!k&(1<<(m-i-1)))
        {

            //这一个判断条件是自己约定的,
            //可以试验得不管用if(!k&(1<<(m-i-1)))
            //还是if(k&(1<<(m-i-1)))
            //最后结果都一样,因为每次约定相同,就不会有枚举遗漏的状态

            flip(0,i);//自己约定,保持一致,避免情况遗漏
        }
    }

    for(int i=1;i<n;i++)
    {
        for(int j=0;j<m;j++)
        {
            if(temp[i-1][j]==1)
            {
                flip(i,j);
            }
        }
    }
    for(int i=0;i<m;i++)
    {
        if(temp[n-1][i]==1)
        {
            return false;
        }
    }
    return true;
}
int main()
{

    while(cin>>n>>m)
    {
        memset(point,0,sizeof(point));
    ans = 999999999;
    memset(vis,0,sizeof(num));
    memset(temp,0,sizeof(temp));
    for(int i=0;i<n;i++)
    {
        for(int j=0;j<m;j++)
        {
            cin>>point[i][j];
        }
    }
    int p = -1;
    for(int i=0;i<(1<<m);i++)
    {
        cnt = 0;
        memset(num,0,sizeof(num));
        if(menum(i)!=false&&cnt<ans)
        {
            ans = cnt;
            p = i;
        }
    }
    if(p>=0)
    {
        memset(num,0,sizeof(num));
        menum(p);//状态重现
        for(int i =0;i<n;i++)
        {
            for(int j = 0;j<m-1;j++)
            {
                cout<<num[i][j]<<" ";
            }
            cout<<num[i][m-1]<<endl;
        }
    }
    else
    {
        cout<<"IMPOSSIBLE"<<endl;
    }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值