HDU - 1074 Doing Homework

HDU - 1074 Doing Homework

题目

Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test, 1 day for 1 point. And as you know, doing homework always takes a long time. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=15) which indicate the number of homework. Then N lines follow. Each line contains a string S(the subject’s name, each string will at most has 100 characters) and two integers D(the deadline of the subject), C(how many days will it take Ignatius to finish this subject’s homework).

Note: All the subject names are given in the alphabet increasing order. So you may process the problem much easier.

Output

For each test case, you should output the smallest total reduced score, then give out the order of the subjects, one subject in a line. If there are more than one orders, you should output the alphabet smallest one.

Sample Input

2
3
Computer 3 3
English 20 1
Math 3 2
3
Computer 3 3
English 6 3
Math 6 3

Sample Output

2
Computer
Math
English
3
Computer
English
Math

Hint

In the second test case, both Computer->English->Math and Computer->Math->English leads to reduce 3 points, but the
word “English” appears earlier than the word “Math”, so we choose the first order. That is so-called alphabet order.

题目大意
给出n个学科作业写完所需要的时间C和提交截至时间D,若提交作业时间超过截止日期,超过一天扣一分,问怎样安排写作业的顺序使得被扣分数最小
解题思路
  • 课程数目很小,最多只有15门,可用二进制表示所有情况[状态压缩]
  • 枚举所有状态,然后对每一种状态的每一位继续枚举
    • 如,当前状态为101,则101可有100或001转换而来
  • 使用结构体记录父节点(路径)
具体实现
//D状态压缩
#include <iostream>
#include <cstring>
#include <string>
#include <algorithm>
#include <cmath>
#include <cstdio>
#include <stack>
using namespace std;

#define INF 0x3f3f3f3f

struct subject
{
    string name;
    int d;
    int t;
};

struct path
{
    int cost;//花费的时间
    int score;//扣掉的分数
    int father;//前一个状态
    int now;//现在添加的作业

};
#define N 16
subject sub[N];
path dp[1<<N];


int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        memset(dp,0,sizeof(dp));
        int n;
        cin>>n;
        for(int i=0;i<n;i++)
        {
            cin>>sub[i].name>>sub[i].d>>sub[i].t;
        }
        int en = 1<<n;
        for(int i=1;i<en;i++)
        {
            int pre = i;
            dp[i].score = INF;
            for(int j=n-1;j>=0;j--)
            {
                int temp = 1<<j;
                if(pre&temp)//若pre这个状态包含做完j作业
                {
                    //算出pre状态在做j作业之前的状态
                    int tmp = pre-temp;
                    int t_score = dp[tmp].cost+sub[j].t-sub[j].d;
                    if(t_score<0)
                    {
                        t_score = 0;
                    }
                    if(t_score+dp[tmp].score<dp[pre].score)
                    {
                    //更新dp数组
                        dp[pre].score = t_score+dp[tmp].score;
                        dp[pre].father = tmp;
                        dp[pre].now = j;
                        dp[pre].cost = dp[tmp].cost+sub[j].t;

                    }
                }

            }
        }
        stack<int>s;
        int t = en-1;
        cout<<dp[t].score<<endl;

        while(t)
        {
            s.push(dp[t].now);
            t = dp[t].father;
        }
        //cout<<"size:"<<s.size()<<endl;
        while(!s.empty())
        {
            cout<<sub[s.top()].name<<endl;
            s.pop();
        }
    }
    return 0;

}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值