[Zoj 1602] Multiplication Puzzle


Problem Description
The multiplication puzzle is played with a row of cards, each containing a single positive integer. During the move player takes one card out of the row and scores the number of points equal to the product of the number on the card taken and the numbers on the cards on the left and on the right of it. It is not allowed to take out the first and the last card in the row. After the final move, only two cards are left in the row.

The goal is to take cards in such order as to minimize the total number of scored points.

For example, if cards in the row contain numbers 10 1 50 20 5, player might take a card with 1, then 20 and 50, scoring
10*1*50 + 50*20*5 + 10*50*5 = 500+5000+2500 = 8000

If he would take the cards in the opposite order, i.e. 50, then 20, then 1, the score would be
1*50*20 + 1*20*5 + 10*1*5 = 1000+100+50 = 1150.

Input
The first line of the input file contains the number of cards N (3 <= N <= 100). The second line contains N integers in the range from 1 to 100, separated by spaces.

Process to the end of file.

Output
Output file must contain a single integer - the minimal score.

Sample Input
6
10 1 50 50 20 5
Sample Output
3650


分析:考虑状态的转换很容易想到区间dp。state[i][j]表示其子问题只有S[i,j]这段区间的数的最小结果。状态转移:考虑区间合并,设s[k]是[i,j]中最后一个删除的数,有状态转移state[i][j] = state[i][j] + state[k][j] + s[i] * s[k] * s[j]。取min即可。


代码:

#include <bits/stdc++.h>
using namespace std;
typedef long long ll;
const int INF = 0x3f3f3f3f;
const int N = 100;
int s[N + 1], dp[N + 1][N + 1];
int main()
{
    int n;
    while (cin >> n)
    {
        for (int i = 1; i <= n; i++)
            cin >> s[i];
        for (int i = 3; i <= n; i++)//区间大小
            for (int j = 1; j + i - 1 <= n; j++)
            {
                int k = j + i - 1;
                dp[j][k] = INF;
                for (int l = j + 1; l < k; l++)
                    dp[j][k] = min(dp[j][k], dp[j][l] + dp[l][k] + s[j] * s[l] * s[k]);
            }
        cout << dp[1][n] << endl;
    }
    return 0;
}
  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值