[Lightoj 1422] Halloween Costumes

链接:


Problem Description
Gappu has a very busy weekend ahead of him. Because, next weekend is Halloween, and he is planning to attend as many parties as he can. Since it’s Halloween, these parties are all costume parties, Gappu always selects his costumes in such a way that it blends with his friends, that is, when he is attending the party, arranged by his comic-book-fan friends, he will go with the costume of Superman, but when the party is arranged contest-buddies, he would go with the costume of ‘Chinese Postman’.

Since he is going to attend a number of parties on the Halloween night, and wear costumes accordingly, he will be changing his costumes a number of times. So, to make things a little easier, he may put on costumes one over another (that is he may wear the uniform for the postman, over the superman costume). Before each party he can take off some of the costumes, or wear a new one. That is, if he is wearing the Postman uniform over the Superman costume, and wants to go to a party in Superman costume, he can take off the Postman uniform, or he can wear a new Superman uniform. But, keep in mind that, Gappu doesn’t like to wear dresses without cleaning them first, so, after taking off the Postman uniform, he cannot use that again in the Halloween night, if he needs the Postman costume again, he will have to use a new one. He can take off any number of costumes, and if he takes off k of the costumes, that will be the last k ones (e.g. if he wears costume A before costume B, to take off A, first he has to remove B).

Given the parties and the costumes, find the minimum number of costumes Gappu will need in the Halloween night.

Input
Input starts with an integer T (≤ 200), denoting the number of test cases.

Each case starts with a line containing an integer N (1 ≤ N ≤ 100) denoting the number of parties. Next line contains N integers, where the ith i t h integer ci c i (1 ≤ ci c i ≤ 100) denotes the costume he will be wearing in party i. He will attend party 1 first, then party 2, and so on.

Output
For each case, print the case number and the minimum number of required costumes.

Sample Input
2
4
1 2 1 2
7
1 2 1 1 3 2 1
Sample Output
Case 1: 3
Case 2: 4


题目大意:万圣节那天Gappu要去参加一系列派对(时间从早到晚),每个派对都要穿特定的戏服才能参加,Gappu可以做到穿很多戏服,一件套在一件上。Gappu在每个派对开始前可以穿一件新的该派对要求的戏服,如果他 之前参加过同种类型的派对并且身上还穿着该种戏服 他可以脱掉若干件戏服(脱掉的衣服不能再穿了) 使这件戏服成为最外面的衣服,再参加这场派对。求他参加这一系列派对所需要的戏服的最小数量。


分析:考虑贪心未果。。于是想到dp,想了半天状态,发现是区间dp。state[i][j]表示 只考虑第i到第j场所需最小戏服数量。则状态转移有两个:

  • state[i][j] = state[i][j - 1] + 1 表示参加第j场穿了一件新戏服
  • state[i][j] = state[i][k - 1] + state[k][j - 1] 表示参加第i场时穿的是第k场的戏服。

第一个式子是显而易见的。。至于第二个式子为什么是这样,是因为对于一个区间,Gappu参加完这一个区间的派对后身上穿的衣服一定是这个区间里的某一件,而把[i, j - 1]区间分成[i, k - 1]和[k, j - 1]是对应在参加第j场时身上还套着第k场时的戏服。


**代码:**C++

#include <bits/stdc++.h>
using namespace std;
typedef long long ll;
const int N = 100;
int s[N + 1], dp[N + 1][N + 1];
int main()
{
    int t;
    cin >> t;
    for (int cas = 1; cas <= t; cas++)
    {
        int n;
        cin >> n;
        for (int i = 1; i <= n; i++)
            cin >> s[i];
        for (int i = 1; i <= n; i++)//区间大小 
            for (int j = 1; j + i - 1 <= n; j++)
            {
                int k = j + i - 1;//dp[j][k]
                dp[j][k] = dp[j][k - 1] + 1;
                for (int l = j; l < k; l++)
                    if (s[l] == s[k])
                        dp[j][k] = min(dp[j][k], dp[j][l - 1] + dp[l][k - 1]);
            }
        cout << "Case " << cas << ": " << dp[1][n] << endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
Sigma函数是指一个数字的所有因子之和。给定一个数字n,需要求出有多少个数字的Sigma函数是偶数。\[2\] 为了解决这个问题,可以先筛选出n范围内的素数(范围在10^6即可),然后对n进行素因子分解。对于每个因子,如果它的Sigma函数中连乘的每一项都是偶数,那么整个Sigma函数就是偶数。具体实现中,可以判断每个因子的平方根是否为偶数,如果是偶数,则减去(平方根+1)/2。\[1\] 另外,还可以使用O(1)的做法来解决这个问题。根据观察,所有的完全平方数及其两倍的值都会导致Sigma函数为偶数。因此,可以直接计算n的平方根,然后减去(平方根+1)/2即可得到结果。\[3\] #### 引用[.reference_title] - *1* [Sigma Function](https://blog.csdn.net/PNAN222/article/details/50938232)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v91^control_2,239^v3^insert_chatgpt"}} ] [.reference_item] - *2* *3* [【LightOJ1336】Sigma Function(数论)](https://blog.csdn.net/qq_30974369/article/details/79009498)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v91^control_2,239^v3^insert_chatgpt"}} ] [.reference_item] [ .reference_list ]

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值