FZU 2111【 Min Number】

Description

Now you are given one non-negative integer n in 10-base notation, it will only contain digits ('0'-'9'). You are allowed to choose 2 integers i and j, such that: i!=j, 1≤i<j≤|n|, here |n| means the length of n’s 10-base notation. Then we can swap n[i] and n[j].

For example, n=9012, we choose i=1, j=3, then we swap n[1] and n[3], then we get 1092, which is smaller than the original n.

Now you are allowed to operate at most M times, so what is the smallest number you can get after the operation(s)?

Please note that in this problem, leading zero is not allowed!

Input

The first line of the input contains an integer T (T≤100), indicating the number of test cases.

Then T cases, for any case, only 2 integers n and M (0≤n<10^1000, 0≤M≤100) in a single line.

Output

For each test case, output the minimum number we can get after no more than M operations.

Sample Input

3
9012 0
9012 1
9012 2

Sample Output

9012
1092
1029


用原串与最小的排列顺序进行比较。

一位一位的比较就行了。不一样就换一次、



#include <iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<algorithm>
using namespace std;
char s[1110],s1[1110],s2[1110];
int main()
{
    int t,n;
    char tmp;
    scanf("%d",&t);
    while(t--)
    {
        memset(s,0,sizeof(s));
        memset(s1,0,sizeof(s1));

        scanf("%s%d",s,&n);
        strcpy(s1,s);//复制
        int len=strlen(s1);
        sort(s1,s1+len);
        if(s1[0]=='0')//第一个位置不为0
        {
            for(int i=0; i<len; i++)
            {
                if(s1[i]!='0')
                {
                    tmp=s1[i];
                    s1[i]=s1[0];
                    s1[0]=tmp;
                    break;

                }
            }
        }
        //此时是s1是最小排序

        while(n--)
        {
            int flag=0;
            for(int i=0; i<len; i++)
            {
                if(s[i]!=s1[i])//逐位扫描
                {
                    for(int j=i; j<len; j++)
                    {
                        if(s[j]==s1[i])
                        {
                            tmp=s[j];
                            s[j]=s[i];
                            s[i]=tmp;
                            flag=1;
                            break;
                        }
                    }
                }
                if(flag)
                    break;
                }
        }

        for(int i=0; i<len; i++)
            printf("%c",s[i]);
        cout<<endl;



    }

    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值