A + B Problem II—1002

Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

Output
For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line is the an equation “A + B = Sum”, Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

Sample Input

2
1 2
112233445566778899 998877665544332211

Sample Output

Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

分析
  考虑到数据会超出机器整形表示范围,用字符串代替整数来进行加法运算。

C++代码

/************************************************* 
Copyright: 武汉大学计算机学院B507 
Author: Ryan
Date: 2015-11-25 
Description:超大整数加法运算 
**************************************************/ 
#include<iostream>
#include<string>
using namespace std;

int main() {
    int n;
    string a,b,sum;
    //carry表示进位,有进位时为1,没有进位时为0。
    int carry=0;
    cin>>n;
    for(int i=1;i<=n;i++){
        cin>>a>>b;
        cout<<"Case "<<i<<":"<<endl;
        cout<<a<<" + "<<b<<" = ";
        sum="";
        //对字符串进行扩充是的两个字符串长度一样。
        int m = a.size()-b.size();
        if(a.size()>b.size()) {
            string::iterator it = b.begin();
            b.insert(it,m,'0');
        }
        else if(a.size()<b.size()){
            string::iterator it = a.begin();
            a.insert(it,-m,'0');
        }

        for(int j=a.size()-1;j>=0;j--){
            int temp = (a[j]-'0')+(b[j]-'0')+carry;
            if(temp>=10){
                carry=1;
                temp=temp-10;
            }
            else{
                carry=0;
            }
            char c = temp+'0';
            sum=c+sum;
        }
        if(carry){
            sum='1'+sum;
        }
        cout<<sum;

        if(i<n)
            cout<<endl<<endl;
        else
            cout<<endl;
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值