彩票的号码有 6 位数字,若一张彩票的前 3 位上的数之和等于后 3 位上的数之和,则称这张彩票是幸运的。本题就请你判断给定的彩票是不是幸运的。
输入格式:
输入在第一行中给出一个正整数 N(≤ 100)。随后 N 行,每行给出一张彩票的 6 位数字。
输出格式:
对每张彩票,如果它是幸运的,就在一行中输出 You are lucky!;否则输出 Wish you good luck.。
输入样例:
2
233008
123456
输出样例:
You are lucky!
Wish you good luck.
#include <bits/stdc++.h>
#include <cmath>
using namespace std;
int getn(char ch)
{
return ch-'0';
}
bool check(string s)
{
int a=getn(s[0])+getn(s[1])+getn(s[2]);
int b=getn(s[3])+getn(s[4])+getn(s[5]);
if(a==b)return true;
else return false;
}
int main() {
int n;cin>>n;
for(int i=0;i<n;i++)
{
string s;cin>>s;
if(check(s))cout<<"You are lucky!\n";
else cout<<"Wish you good luck.\n";
}
return 0;
}