PAT 1122 Hamiltonian Cycle

1122. Hamiltonian Cycle (25)

时间限制
300 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

The "Hamilton cycle problem" is to find a simple cycle that contains every vertex in a graph. Such a cycle is called a "Hamiltonian cycle".

In this problem, you are supposed to tell if a given cycle is a Hamiltonian cycle.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers N (2< N <= 200), the number of vertices, and M, the number of edges in an undirected graph. Then M lines follow, each describes an edge in the format "Vertex1 Vertex2", where the vertices are numbered from 1 to N. The next line gives a positive integer K which is the number of queries, followed by K lines of queries, each in the format:

n V1 V2 ... Vn

where n is the number of vertices in the list, and Vi's are the vertices on a path.

Output Specification:

For each query, print in a line "YES" if the path does form a Hamiltonian cycle, or "NO" if not.

Sample Input:
6 10
6 2
3 4
1 5
2 5
3 1
4 1
1 6
6 3
1 2
4 5
6
7 5 1 4 3 6 2 5
6 5 1 4 3 6 2
9 6 2 1 6 3 4 5 2 6
4 1 2 5 1
7 6 1 3 4 5 2 6
7 6 1 2 5 4 3 1
Sample Output:
YES
NO
NO
NO
YES
NO
//起点终点相同,路径共n+1个点,路径无重复点,路径为通路
#include <cstdio>
#include <cstring>
#include <iostream>
using namespace std;
int map[205][205];
int main(){
	int n,m;
	int t,count,flag;
	int x,y,start;
	int book[205];
	cin>>n>>m;
	memset(map,0,sizeof(int)*(205*205));
	for(int i=1;i<=m;i++){
		cin>>x>>y;
		map[x][y]=map[y][x]=1;
	}
	cin>>t;
	for(int i=1;i<=t;i++){
		flag=1;
		memset(book,0,sizeof(book));
		cin>>count;
		if(count!=n+1){
			flag=0;
		}
		cin>>start;
		x=start;
		book[start]=1;
		for(int j=1;j<=count-1;j++){
			cin>>y;
			if(j!=count-1&&book[y]){
				flag=0;
			}
			book[y]=1;
			if(map[x][y]==0){
				flag=0;
			}
			x=y;
		}
		if(x!=start){
			flag=0;
		}
		if(flag)
			cout<<"YES"<<endl;
		else
			cout<<"NO"<<endl;
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值