Poj 2253 Frogger(最小生成树的最大边)

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists' sunscreen, he wants to avoid swimming and instead reach her by jumping. 
Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps. 
To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence. 
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones. 


You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the frog distance between Freddy's and Fiona's stone. 
Input
The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy's stone, stone #2 is Fiona's stone, the other n-2 stones are unoccupied. There's a blank line following each test case. Input is terminated by a value of zero (0) for n.
Output
For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.
Sample Input
2
0 0
3 4


3
17 4
19 4
18 5


0
Sample Output
Scenario #1
Frog Distance = 5.000


Scenario #2

Frog Distance = 1.414


法一:搜索,会超时

法二:仔细想想,题意为从起点到终点的所有路径中,每条路径上的最大值,再取最小值。难的是想到去用求最小生成树的prim算法去解决该题。从起点开始构建最小生成树,直到把终点加入,停止构造,此过程加的最大的边极为到达终点的那条边,即为题目所求。对于正确性,可以证明,构造最小生成树为一个贪心的过程,每一步都添加尽量短的边,所以此过程能满足要求,若走另一条路去终点,肯定会遇到比得到的结果更大的边。该过程要仔细想一想......


红点为起点终点,绿数字为加边顺序,红线为构造过程,黄线为需要的路径


#include <cstdio>
#include <cstring>
#include <queue>
#include <algorithm>
#include <iostream>
#include <cmath>
using namespace std;
int loc[205][2];
double map[205][205];
int n;
struct node{
	int to;
	double dis;
	node(int a,double b):to(a),dis(b){}
	bool operator <(const node& c)const{
		return this->dis>c.dis;
	}
};
double Dis(int x,int y){
	return sqrt(pow(loc[x][0]-loc[y][0],2)+pow(loc[x][1]-loc[y][1],2));
}
void Prim(int cases){
	priority_queue<node> q;
	double distance[205],Max=-1;
	int book[205];
	memset(book,0,sizeof(book));
	for(int i=1;i<=n;i++){
		distance[i]=1e8;
	}
	distance[1]=0.0;
	q.push(node(1,0.0));
	while(!q.empty()){
		node head=q.top();
		q.pop();
		if(book[head.to]){
			continue;
		}
		Max=max(Max,head.dis);
		book[head.to]=1;
		if(head.to==2){
			break;
		}
		for(int i=1;i<=n;i++){
			if(i==head.to){
				continue;
			}
			if(distance[i]>map[head.to][i]){
				distance[i]=map[head.to][i];
				q.push(node(i,distance[i]));
			}
		}
	}
	printf("Scenario #%d\n",cases);
	printf("Frog Distance = %.3f\n",Max);
	return;
}
int main(){
	int x,y,count=0;
	while(cin>>n&&n){
		for(int i=1;i<=n;i++){
			cin>>x>>y;
			loc[i][0]=x;
			loc[i][1]=y;
		}
		for(int i=1;i<n;i++){
			for(int j=i+1;j<=n;j++){
				map[i][j]=map[j][i]=Dis(i,j);
			}
		}
		Prim(++count);
		cout<<endl;
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值