POJ 2955 - Brackets

Brackets

We give the following inductive definition of a “regular brackets” sequence:

the empty sequence is a regular brackets sequence,
if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and
if a and b are regular brackets sequences, then ab is a regular brackets sequence.
no other sequence is a regular brackets sequence
For instance, all of the following character sequences are regular brackets sequences:

(), [], (()), ()[], ()[()]

while the following character sequences are not:

(, ], )(, ([)], ([(]

Given a brackets sequence of characters a1a2 … an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such that for indices i1, i2, …, im where 1 ≤ i1 < i2 < … < im ≤ n, ai1ai2 … aim is a regular brackets sequence.

Given the initial sequence ([([]])], the longest regular brackets subsequence is [([])].

Input

The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters (, ), [, and ]; each input test will have length between 1 and 100, inclusive. The end-of-file is marked by a line containing the word “end” and should not be processed.

Output

For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.

Sample Input

((()))
()()()
([]])
)[)(
([][][)
end

Sample Output

6
6
4
0
6

题意

给你一串字符串,判断有多少个括号配对

思路

1 类似POJ 1141 的那道括号匹配问题,这里我们只需要转换一下,求最少加上多少个括号就能使所有的括号匹配,然后用总长度减去需要加上的括号,极为匹配的括号,
dp[i][j]表示i道j最少需要加上多少个括号,

代码

#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;

int const INF=0x3fffffff;
char s[205];
int dp[205][205];

int main(){
    while(scanf("%s",s)!=EOF&&strcmp(s,"end")!=0){
        memset(dp,0,sizeof(dp));
        int len=strlen(s);
        for(int i=0;i<len;++i)
            dp[i][i]=1;
        for(int k=1;k<len;++k)
        for(int i=0;i<len-1;++i){
            dp[i][i+k]=INF;
            if((s[i]=='('&&s[i+k]==')')||(s[i]=='['&&s[i+k]==']'))
                dp[i][i+k]=dp[i+1][i+k-1];
            for(int j=i;j<i+k;++j)
                dp[i][i+k]=min(dp[i][i+k],dp[i][j]+dp[j+1][i+k]);
        }
        printf("%d\n",len-dp[0][len-1]);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值