Largest Submatrix of All 1’s POJ - 3494

题目链接:点我


    Given a m-by-n (0,1)-matrix, of all its submatrices of all 1’s which is the largest? By largest we mean that the submatrix has the most elements.

Input

    The input contains multiple test cases. Each test case begins with m and n (1 ≤ m, n ≤ 2000) on line. Then come the elements of a (0,1)-matrix in row-major order on m lines each with n numbers. The input ends once EOF is met.

Output

    For each test case, output one line containing the number of elements of the largest submatrix of all 1’s. If the given matrix is of all 0’s, output 0.

Sample Input

2 2
0 0
0 0
4 4
0 0 0 0
0 1 1 0
0 1 1 0
0 0 0 0

Sample Output

0
4

题意:

给你一个 n * m 的01矩阵,求矩阵中由1组成的最大矩阵的面积.

思路:

单调栈,先预处理以当前行为底边的矩阵所能组成的最大矩阵的高度,即当前坐标上面包括了多少个连续的1,然后,每一行维护一个单调递增的栈,如果当前高度大于栈中的最大高度,直接入栈,否则,栈顶元素出栈,并记录出栈元素的个数,然后以此个数和出栈元素的高度来更新ans.

代码:

#include<cstdio>
#include<algorithm>
#include<cstring>
#include<iostream>
#include<cmath>
#include<queue>
using namespace std;

const int maxn = 2000+10;
int w[maxn];
struct ss{
    int v, d;
} a[maxn];

inline int Max(int a, int b){
    return a > b ? a : b;
}

int main(){
    int n, m;
    while(scanf("%d %d", &n, &m) != EOF){
        int ans = 0;
        memset(w,0,sizeof(w));
        for(int  i = 1;i <= n;++i){
            int r = 0;
            for(int j = 1;j <= m;++j){
                int x;
                scanf("%d", &x);
                w[j] = x ? w[j] + 1 : 0;//记录当前元素为低的矩形的高度
                if(r && a[r].v > w[j]){
                while(0 < r && a[r].v > w[j]){//栈顶元素出栈
                   ans = max(ans, a[r].v * (j -a[r].d));
                    r--;
                }
                if(w[j])
                    a[++r].v = w[j];
                }else {
                    a[++r].v = w[j];
                    a[r].d = j;
                    if(r >= 2 && a[r-1].v == a[r].v)
                        a[r].d = a[r-1].d;
                }
            }
                while(r>0){
                    ans=Max(ans,a[r].v * ( m + 1 - a[r].d));
                    r--;
                }
            }
            printf("%d\n",ans);
        }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值