poj 3494 单调栈

Given a m-by-n (0,1)-matrix, of all its submatrices of all 1’s which is the largest? By largest we mean that the submatrix has the most elements.

Input

The input contains multiple test cases. Each test case begins with m and n (1 ≤ mn ≤ 2000) on line. Then come the elements of a (0,1)-matrix in row-major order on mlines each with n numbers. The input ends once EOF is met.

Output

For each test case, output one line containing the number of elements of the largest submatrix of all 1’s. If the given matrix is of all 0’s, output 0.

Sample Input
2 2
0 0
0 0
4 4
0 0 0 0
0 1 1 0
0 1 1 0
0 0 0 0
Sample Output
0

4

题意:给你一个0,1矩阵,然后让你找到里边最大的全1矩阵

思路:这个我们也用到了单调栈,我们枚举每一行然后每一行我们对h数组进行一次从前往后的单调递增栈,从后往前也进行一次单调递增栈,

小矩形的高度h[j]就是从该行开始往上的最大的连续1的个数,然后我们找最大值就可以了

ac代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <stack>
const int maxn=1e5+5;
using namespace std;
int h[maxn],l[maxn],r[maxn];
int main()
{
    int n,m;
    while(cin>>n>>m)
    {
        int ph;
        memset(h,0,sizeof(h));
        int max1=-1;
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=m;j++)
            {
               scanf("%d",&ph);
               if(ph==0)
               h[j]=0;
               else
               h[j]++;
            }
            stack<int> s;
            for(int j=1;j<=m;j++)
            {
                while(!s.empty()&&h[s.top()]>=h[j])
                s.pop();
                if(s.empty())
                l[j]=1;
                else
                l[j]=s.top()+1;
                s.push(j);
            }
            stack<int> p;
            for(int j=m;j>=1;j--)
            {
                while(!p.empty()&&h[p.top()]>=h[j])
                p.pop();
                if(p.empty())
                r[j]=m;
                else
                r[j]=p.top()-1;
                p.push(j);
            }
            for(int j=1;j<=m;j++)
            {
                max1=max(h[j]*(r[j]-l[j]+1),max1);
            }
        }
        cout<<max1<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值