Parity game POJ - 1733(带权并查集 + 离散化)

题目链接:点我


Now and then you play the following game with your friend. Your friend writes down a sequence consisting of zeroes and ones. You choose a continuous subsequence (for example the subsequence from the third to the fifth digit inclusively) and ask him, whether this subsequence contains even or odd number of ones. Your friend answers your question and you can ask him about another subsequence and so on. Your task is to guess the entire sequence of numbers.

You suspect some of your friend's answers may not be correct and you want to convict him of falsehood. Thus you have decided to write a program to help you in this matter. The program will receive a series of your questions together with the answers you have received from your friend. The aim of this program is to find the first answer which is provably wrong, i.e. that there exists a sequence satisfying answers to all the previous questions, but no such sequence satisfies this answer. 

Input

The first line of input contains one number, which is the length of the sequence of zeroes and ones. This length is less or equal to 1000000000. In the second line, there is one positive integer which is the number of questions asked and answers to them. The number of questions and answers is less or equal to 5000. The remaining lines specify questions and answers. Each line contains one question and the answer to this question: two integers (the position of the first and last digit in the chosen subsequence) and one word which is either `even' or `odd' (the answer, i.e. the parity of the number of ones in the chosen subsequence, where `even' means an even number of ones and `odd' means an odd number). 

Output

There is only one line in output containing one integer X. Number X says that there exists a sequence of zeroes and ones satisfying first X parity conditions, but there exists none satisfying X+1 conditions. If there exists a sequence of zeroes and ones satisfying all the given conditions, then number X should be the number of all the questions asked. 

Sample Input

10
5
1 2 even
3 4 odd
5 6 even
1 6 even
7 10 odd

Sample Output

3

题意:

一段由0 1 构成的序列,现在给你几段连续的序列中包含的 0 的个数是奇数还是偶数,问你第一个错误的说法出现在第几个.

思路:

带权并查集,用权值维护某一段区间内的 0 的个数是奇数还是偶数,由于题目数据很大,所以我们需要对题目的区间进行离散化处理.

代码:

#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<iostream>
#include<map>
using namespace std;

int b[10000+10];
struct ss{
    int x,y;
    char op[10];
}a[5000+10];
int f[10000+10];
int r[10000+10];
map<int ,int > q;

int getf(int x){
    if(f[x] == x) return x;
    int tmp = f[x];
    f[x] = getf(f[x]);
    r[x] = r[tmp]^r[x];
    return f[x];
}

int Merge(int x, int y, int k){
    int t1 = getf(x);
    int t2 = getf(y);

    if(t1 != t2){
        f[t1] = t2;
        r[t1] = r[x] ^ r[y] ^ k;//这里的位运算刚刚好符合0 1 变换的规律
        return 0;
    } else if (((r[x] == r[y]) && k) || (( r[x] != r[y]) && !k))
               return 1;
    return 0;
}

int main(){
    int n, m;
    while(scanf("%d", &n) != EOF){
        scanf("%d", &m);
        int num = 0, ans=0, k, flag = 0;
        for(int i = 1; i <= m; ++i){
            scanf("%d %d %s", &a[i].x, &a[i].y, &a[i].op);
            a[i].x--;
            b[num++] = a[i].x;
            b[num++] = a[i].y;
        }sort(b, b + num);
        num = unique(b, b + num) - b;
        for(int  i = 0; i < num; ++i)//离散化处理
            q[b[i]] = i+1;
        memset(r, 0, sizeof(r));
        for(int  i = 0; i <= num; ++i)
            f[i] = i;
        for(int  i = 1; i <= m; ++i){
            if(flag)  break;//表示找到了冲突的
           int x = q[a[i].x];
            int y = q[a[i].y];
            if(a[i].op[0] == 'o')// 1 表示是奇数, 0 表示偶数,
                k = 1;
            else k = 0;
            if (!Merge(x, y, k))
                ans++;
            else
                break;//这个地方很迷,我让ans = i - 1就是错的
        }printf("%d\n",ans);
    }return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值