poj 3321 难度:一般

点击打开链接

Apple Tree
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 30842 Accepted: 9233

Description

There is an apple tree outside of kaka's house. Every autumn, a lot of apples will grow in the tree. Kaka likes apple very much, so he has been carefully nurturing the big apple tree.

The tree has N forks which are connected by branches. Kaka numbers the forks by 1 to N and the root is always numbered by 1. Apples will grow on the forks and two apple won't grow on the same fork. kaka wants to know how many apples are there in a sub-tree, for his study of the produce ability of the apple tree.

The trouble is that a new apple may grow on an empty fork some time and kaka may pick an apple from the tree for his dessert. Can you help kaka?

Input

The first line contains an integer N (N ≤ 100,000) , which is the number of the forks in the tree.
The following N - 1 lines each contain two integers u and v, which means fork u and fork v are connected by a branch.
The next line contains an integer M (M ≤ 100,000).
The following M lines each contain a message which is either
"x" which means the existence of the apple on fork x has been changed. i.e. if there is an apple on the fork, then Kaka pick it; otherwise a new apple has grown on the empty fork.
or
"x" which means an inquiry for the number of apples in the sub-tree above the fork x, including the apple (if exists) on the fork x
Note the tree is full of apples at the beginning

Output

For every inquiry, output the correspond answer per line.

Sample Input

3
1 2
1 3
3
Q 1
C 2
Q 1

Sample Output

3
2

题意:给你一颗苹果树,每个树杈有且只有一个苹果,注意不是二叉树是多叉树,Q: x表示x节点开始所有子树的苹果树之和,C:x表示如果x节点没有苹果,就加上一个苹果,如果右苹果,就减去一个苹果。

思路:看了别人的博客学会的  : 点击打开链接

先记录每个节点所涵盖子树的区间范围,接下来就是树状数组区间求和的问题了,注意这题vector有点坑,代码有注释。

#include<cstdio>
#include<vector>
using namespace std;
int left[200001],right[200001];
int c[200000];
int flag[200001];
int tot,n;
vector<vector<int> >G(100001);
//vector<int>这种会超时,要用上面这种 
void dfs(int u)
{
	left[u]=tot;//记录该节点的子树左区间 
	for(int i=0;i<G[u].size();i++)
	{
		tot++;
		dfs(G[u][i]);
	}
	right[u]=tot;//记录该节点的子树右区间 
}
void add(int i,int key)
{
	while(i<=n)
	{
		c[i]+=key;
		i+=i&(-i);
	}
}
int sum(int i)
{
	int ans=0;
	while(i>0)
	{
		ans+=c[i];
		i-=i&(-i);
	}
	return ans;
}
int main()
{
	int m;
	while(~scanf("%d",&n))
	{
		int i,u,v,t;
		char ch[2];
		for(i=0;i<=n;i++)
		{
			G[i].clear();
			flag[i]=c[i]=0;
		}
		for(i=1;i<n;i++)
		{
			scanf("%d%d",&u,&v);
			G[u].push_back(v);
		}
		tot=1;
		dfs(1);//计算每个节点的子树区间范围 
		for(i=1;i<=n;i++)
		add(i,1);
		scanf("%d",&m);
		while(m--)
		{
			scanf("%s",ch);
			if(ch[0]=='Q')
			{
				scanf("%d",&t);
				printf("%d\n",sum(right[t])-sum(left[t]-1));//子树右区间的和-左区间的和 
			}
			else
			{
				scanf("%d",&t);
				if(!flag[t])
				{
					flag[t]=1;
					add(left[t],-1);//从该节点的子树做区间开始更新 
				}
				else
				{
					flag[t]=0;
					add(left[t],1);
				}
			}
		}
	}
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

长沙橘子猫

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值