Reversing Linked List

14 篇文章 0 订阅

Given a constant K and a singly linked list L, you are supposed to reverse the links of every K elements on L. For example, given L being 1→2→3→4→5→6, if K = 3, then you must output 3→2→1→6→5→4; if K = 4, you must output 4→3→2→1→5→6.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (<= 105) which is the total number of nodes, and a positive K (<=N) which is the length of the sublist to be reversed. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is an integer, and Next is the position of the next node.

Output Specification:

For each case, output the resulting ordered linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:
00100 6 4
00000 4 99999
00100 1 12309
68237 6 -1
33218 3 00000
99999 5 68237
12309 2 33218
Sample Output:
00000 4 33218
33218 3 12309
12309 2 00100
00100 1 99999
99999 5 68237
68237 6 -1
#include<iostream>
#include<algorithm>
#include <iomanip>
using namespace std;
int list[100010];
int node[100010][2];//二维数组:行存放地址,列存放元素和下一个地址
int main()
{
    int st,num,k;
    cin>>st>>num>>k;
    int address,data,next,i;
    for(i=0;i<num;i++)
    {
        cin>>address>>data>>next;
        node[address][0]=data;
        node[address][1]=next;
    }
    int m=0,n=st;
    while(n!=-1)//将地址存放在list中
    {
        list[m++]=n;
        n=node[n][1];
    }
	i=0;
    while(i+k<=m)//反转list中的地址
    {
        reverse(list+i,list+i+k);
        i=i+k;
    }
    for(i=0;i<m;i++)
    {
		cout<<right<<setw(5)<<setfill('0')<<list[i]<<" ";//右对齐,元素长度为5,不足补0。这是因为00000的地址输出是0
		cout<<node[list[i]][0]<<" ";
		if(i!=m-1)
			cout<<right<<setw(5)<<setfill('0')<<list[i+1]<<'\n';
		else
			cout<<-1<<'\n';//最后一个行最后一个输出
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值