poj-1094 Sorting It All Out

Description

An ascending sorted sequence of distinct values is one in which some form of a less-than operator is used to order the elements from smallest to largest. For example, the sorted sequence A, B, C, D implies that A < B, B < C and C < D. in this problem, we will give you a set of relations of the form A < B and ask you to determine whether a sorted order has been specified or not.

Input

Input consists of multiple problem instances. Each instance starts with a line containing two positive integers n and m. the first value indicated the number of objects to sort, where 2 <= n <= 26. The objects to be sorted will be the first n characters of the uppercase alphabet. The second value m indicates the number of relations of the form A < B which will be given in this problem instance. Next will be m lines, each containing one such relation consisting of three characters: an uppercase letter, the character "<" and a second uppercase letter. No letter will be outside the range of the first n letters of the alphabet. Values of n = m = 0 indicate end of input.

Output

For each problem instance, output consists of one line. This line should be one of the following three:

Sorted sequence determined after xxx relations: yyy...y.
Sorted sequence cannot be determined.
Inconsistency found after xxx relations.

where xxx is the number of relations processed at the time either a sorted sequence is determined or an inconsistency is found, whichever comes first, and yyy...y is the sorted, ascending sequence.

Sample Input

4 6
A<B
A<C
B<C
C<D
B<D
A<B
3 2
A<B
B<A
26 1
A<Z
0 0

Sample Output

Sorted sequence determined after 4 relations: ABCD.
Inconsistency found after 2 relations.
Sorted sequence cannot be determined.

    题目隐含条件在输出中,需要判断执行多少步后能够完成有序的关系,或者出现环。所以需要每一步都进行一次拓扑排序,找到是否出现符合输出条件的情况。第三中输出需要在图完全建成后才能判断所以第三种输出在输入完毕后判断。

#include <iostream>
#include <algorithm>
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <math.h>
#define INF 0x3f3f3f3f

using namespace std;

int map[30][30];
int du[30];
int du2[30];
char ans[30];
int n,m;
int flag;
void top()
{
    int i,j;
    int l=0,s=0,pos;
    for (i=1;i<=n;i++)
    {
        du2[i]=du[i];
    }
    for (i=1;i<=n;i++)
    {
        s=0;
        for(j=1;j<=n;j++)
        {
            if(du2[j]==0) {s++;pos=j;}
        }
        if(s==0) {flag=1; return ;}
        if(s>1) flag=-1;
        ans[l++]=pos+'A'-1;
        ans[l]='\0';
        du2[pos]=-1;
        for (j=1;j<=n;j++)
        {
            if(map[pos][j])
                du2[j]--;
        }
    }
}

int main()
{
    char str[3];
    int i,j;
    while (scanf("%d%d",&n,&m),n||m)
    {
        int sign=0;
        memset(map,0,sizeof(map));
        memset(du,0,sizeof(du));
        for (i=1;i<=m;i++)
        {
            flag=0;
            scanf("%s",str);
            if(sign) continue;
            du[str[2]-'A'+1]++;
            map[str[0]-'A'+1][str[2]-'A'+1]=1;
            top();
            if(flag==1)
            {
                printf("Inconsistency found after %d relations.\n",i);
                sign=1;
            }
            else if(flag==0)
            {
                printf("Sorted sequence determined after %d relations: %s.\n",i,ans);
                sign=1;
            }
        }
        if(flag==-1)
        {
            printf("Sorted sequence cannot be determined.\n");
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值