HDU-2473 Junk-Mail Filter

Problem Description
Recognizing junk mails is a tough task. The method used here consists of two steps:
1) Extract the common characteristics from the incoming email.
2) Use a filter matching the set of common characteristics extracted to determine whether the email is a spam.

We want to extract the set of common characteristics from the N sample junk emails available at the moment, and thus having a handy data-analyzing tool would be helpful. The tool should support the following kinds of operations:

a) “M X Y”, meaning that we think that the characteristics of spam X and Y are the same. Note that the relationship defined here is transitive, so
relationships (other than the one between X and Y) need to be created if they are not present at the moment.

b) “S X”, meaning that we think spam X had been misidentified. Your tool should remove all relationships that spam X has when this command is received; after that, spam X will become an isolated node in the relationship graph.

Initially no relationships exist between any pair of the junk emails, so the number of distinct characteristics at that time is N.
Please help us keep track of any necessary information to solve our problem.
 

Input
There are multiple test cases in the input file.
Each test case starts with two integers, N and M (1 ≤ N ≤ 10 5 , 1 ≤ M ≤ 10 6), the number of email samples and the number of operations. M lines follow, each line is one of the two formats described above.
Two successive test cases are separated by a blank line. A case with N = 0 and M = 0 indicates the end of the input file, and should not be processed by your program.
 

Output
For each test case, please print a single integer, the number of distinct common characteristics, to the console. Follow the format as indicated in the sample below.
 

Sample Input
  
  
5 6 M 0 1 M 1 2 M 1 3 S 1 M 1 2 S 3 3 1 M 1 2 0 0

Sample Output
  
  
Case #1: 3 Case #2: 2

    题意:说实话题意我也不是很理解,那就直接说核心要求吧,有N个点(从0开始),M个操作,‘M’ x y为将x与y关联,‘S’ x 为将x从关联中移除,但是通过x关联的其他点仍然关联。最后输出该关联图中有几个连通分量。

    思路:很明显的并查集,但是在删除节点上需要做一些手脚,我们让一开始的N个点的位置用一个数组d[]存起来,开始时d[i]=i。随后将某一点移除时将d[x]中的x变为大于n的一个数值,即虚拟节点,之后x点再次连接到图中时使用的是虚拟节点的数值。最后遍历d[]数组查找连通分量个数。

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <cmath>
#define INF 0x3f3f3f3f
#define mod 1000000007
#define maxn e9

using namespace std;

int arr[2000000],d[2000000],Hash[2000000];
int Find(int r)
{
    return arr[r]==r?r:arr[r]=Find(arr[r]);
}
void Union(int x,int y)
{
    int fx=Find(x);
    int fy=Find(y);
    if(fx!=fy)
    {
        arr[fx]=fy;
    }
}
int main()
{
    int i,j=1;
    int n,m,x,y;
    char c;
    while(scanf("%d%d",&n,&m),n||m)
    {
        int ans=0;
        memset(Hash,0,sizeof(Hash));
        for (i=0;i<2000000;i++)
        {
            d[i]=i;
            arr[i]=i;
        }
        int t=n;
        while(m--)
        {
            scanf("%*c%c",&c);
            if(c=='M')
            {
                scanf("%d%d",&x,&y);
                Union(d[x],d[y]);
            }
            else
            {
                scanf("%d",&x);
                d[x]=t++;
            }
        }
        for (i=0;i<n;i++)
        {
            x=Find(d[i]);
            if(!Hash[x])
            {
                Hash[x]++;
                ans++;
            }
        }
        printf("Case #%d: %d\n",j++,ans);
    }
    return 0;
}


基于SSM框架的智能家政保洁预约系统,是一个旨在提高家政保洁服务预约效率和管理水平的平台。该系统通过集成现代信息技术,为家政公司、家政服务人员和消费者提供了一个便捷的在线预约和管理系统。 系统的主要功能包括: 1. **用户管理**:允许消费者注册、登录,并管理他们的个人资料和预约历史。 2. **家政人员管理**:家政服务人员可以注册并更新自己的个人信息、服务类别和服务时间。 3. **服务预约**:消费者可以浏览不同的家政服务选项,选择合适的服务人员,并在线预约服务。 4. **订单管理**:系统支持订单的创建、跟踪和管理,包括订单的确认、完成和评价。 5. **评价系统**:消费者可以在家政服务完成后对服务进行评价,帮助提高服务质量和透明度。 6. **后台管理**:管理员可以管理用户、家政人员信息、服务类别、预约订单以及处理用户反馈。 系统采用Java语言开发,使用MySQL数据库进行数据存储,通过B/S架构实现用户与服务的在线交互。系统设计考虑了不同用户角色的需求,包括管理员、家政服务人员和普通用户,每个角色都有相应的权限和功能。此外,系统还采用了软件组件化、精化体系结构、分离逻辑和数据等方法,以便于未来的系统升级和维护。 智能家政保洁预约系统通过提供一个集中的平台,不仅方便了消费者的预约和管理,也为家政服务人员提供了一个展示和推广自己服务的机会。同时,系统的后台管理功能为家政公司提供了强大的数据支持和决策辅助,有助于提高服务质量和管理效率。该系统的设计与实现,标志着家政保洁服务向现代化和网络化的转型,为管理决策和控制提供保障,是行业发展中的重要里程碑。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值