poj 1201 Intervals

Intervals

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 25360 Accepted: 9688

Description

You are given n closed, integer intervals [ai, bi] and n integers c1, …, cn.
Write a program that:
reads the number of intervals, their end points and integers c1, …, cn from the standard input,
computes the minimal size of a set Z of integers which has at least ci common elements with interval [ai, bi], for each i=1,2,…,n,
writes the answer to the standard output.

Input

The first line of the input contains an integer n (1 <= n <= 50000) – the number of intervals. The following n lines describe the intervals. The (i+1)-th line of the input contains three integers ai, bi and ci separated by single spaces and such that 0 <= ai <= bi <= 50000 and 1 <= ci <= bi - ai+1.

Output

The output contains exactly one integer equal to the minimal size of set Z sharing at least ci elements with interval [ai, bi], for each i=1,2,…,n.

Sample Input
5
3 7 3
8 10 3
6 8 1
1 3 1
10 11 1

Sample Output
6


【分析】
差分约束系统裸题,与tyvj西瓜种植一样,建议大家先去做西瓜种植

传送门在此


【代码】

//tyvj1415 西瓜种植 
#include<iostream>
#include<cstdio>
#include<cstring>
#include<vector>
#define fo(i,j,k) for(int i=j;i<=k;i++)
using namespace std;
vector <int> f[50001];
vector <int> l[50001]; 
int n,m,x,y,d;
int dis[50001],q[5000001];
bool vis[50001];
int main()
{
    memset(dis,0x7f,sizeof dis);
    scanf("%d",&m);
    fo(i,1,m)
    {
        scanf("%d%d%d",&x,&y,&d);
        f[x-1].push_back(y);
        l[x-1].push_back(-d);
        n=max(n,max(x,y));
    }
    fo(i,1,n)
      f[i-1].push_back(i),l[i-1].push_back(0),
      f[i].push_back(i-1),l[i].push_back(1);
    dis[0]=0;
    vis[0]=1;
    int h=0,t=1;
    q[t]=0;
    while(h<t)
    {
        int u=q[++h];
        vis[u]=0;
        int x=f[u].size()-1;
        fo(i,0,x)
        {
            int v=f[u][i];
            if(dis[v]>dis[u]+l[u][i])
            {
                dis[v]=dis[u]+l[u][i];
                if(!vis[v])
                  vis[v]=1,q[++t]=v;
            }
        }
    }
    printf("%d\n",-dis[n]);
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值