poj 1679 The Unique MST

The Unique MST
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 28136 Accepted: 10040
Description

Given a connected undirected graph, tell if its minimum spanning tree is unique.

Definition 1 (Spanning Tree): Consider a connected, undirected graph G = (V, E). A spanning tree of G is a subgraph of G, say T = (V’, E’), with the following properties:
1. V’ = V.
2. T is connected and acyclic.

Definition 2 (Minimum Spanning Tree): Consider an edge-weighted, connected, undirected graph G = (V, E). The minimum spanning tree T = (V, E’) of G is the spanning tree that has the smallest total cost. The total cost of T means the sum of the weights on all the edges in E’.
Input

The first line contains a single integer t (1 <= t <= 20), the number of test cases. Each case represents a graph. It begins with a line containing two integers n and m (1 <= n <= 100), the number of nodes and edges. Each of the following m lines contains a triple (xi, yi, wi), indicating that xi and yi are connected by an edge with weight = wi. For any two nodes, there is at most one edge connecting them.
Output

For each input, if the MST is unique, print the total cost of it, or otherwise print the string ‘Not Unique!’.
Sample Input

2
3 3
1 2 1
2 3 2
3 1 3
4 4
1 2 2
2 3 2
3 4 2
4 1 2
Sample Output

3
Not Unique!


【分析】
求最小生成树是否唯一,如果不唯一,输出NOT,如果唯一,输出最小生成树总边权。
首先用Kruskal求最小生成树,然后记录用到的边。然后枚举这些边被删掉,重新建立最小生成树,如果发现一次新建树的权值=老树的权值,那么就输出not。


【代码】

//poj 1679 The Unique MST
#include<cmath>
#include<cstdio>
#include<cstring>
#include<algorithm>
#define fo(i,j,k) for(i=j;i<=k;i++)
using namespace std;
int father[105],sum[10001];
int n,m,k,T,s,t,ans,top,anss;
struct node
{
    int l,r,v;
}a[10005];
inline bool comp(const node &p,const node &q) {return p.v<q.v;}
inline int find(int x)
{
    if(x!=father[x]) father[x]=find(father[x]);
    return father[x];
}
int main()
{
    int i,j;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d",&n,&m);
        ans=top=t=0;
        bool flag=0;
        fo(i,1,n)
          father[i]=i;
        fo(i,1,m)
          scanf("%d%d%d",&a[i].l,&a[i].r,&a[i].v);
        sort(a+1,a+m+1,comp);
        fo(i,1,m)
          if(find(a[i].l)!=find(a[i].r))
          {
              father[find(a[i].l)]=find(a[i].r);
              sum[++top]=i;
              ans+=a[i].v;
          }
        fo(j,1,top)  //枚举删边 
        {
            anss=t=0;
            fo(k,1,n)
              father[k]=k;
            fo(i,1,m)
              if(i!=sum[j])
              {
                if(find(a[i].l)!=find(a[i].r))
                {
                  t++;
                  father[find(a[i].l)]=find(a[i].r);
                  anss+=a[i].v;
                }
              }
            if(anss==ans && t==n-1) {printf("Not Unique!\n");flag=1;break;}
        }
        if(!flag) printf("%d\n",ans);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值