UVA 10375 Choose and divide

The binomial coefficient C(m, n) is defined as
C(m, n) = m!
(m − n)! n!
Given four natural numbers p, q, r, and s, compute the the result of dividing C(p, q) by C(r, s).
Input
Input consists of a sequence of lines. Each line contains four non-negative integer numbers giving values
for p, q, r, and s, respectively, separated by a single space. All the numbers will be smaller than 10,000
with p ≥ q and r ≥ s.
Output
For each line of input, print a single line containing a real number with 5 digits of precision in the fraction,
giving the number as described above. You may assume the result is not greater than 100,000,000.
Sample Input
10 5 14 9
93 45 84 59
145 95 143 92
995 487 996 488
2000 1000 1999 999
9998 4999 9996 4998
Sample Output
0.12587
505606.46055
1.28223
0.48996
2.00000
3.99960


【分析】
用唯一分解定理把这些数都分解为质因数乘积。算出分子,再算出分母,然后就好了。


【代码】

#include<cstdio>
#include<cstring>
#include<cmath>
const int maxn=10000;
int prm[10010],cnt[10010],tot;
bool have[10010];
void add(int x,int d)
{
    int i,j,tem;
    for (i=2;i<=x;i++)
    {
        tem=i;
        for (j=1;tem>1;j++)
          while (tem%prm[j]==0)
          {
            tem/=prm[j];
            cnt[j]+=d;
          }
    }
}
int main()
{
    int i,j,k,m,n,p,q,r,s,x,y,z;
    double ans;
    for (i=2;i<=maxn;i++)
    {
        if (!have[i]) prm[++tot]=i;
        for (j=1;j<=tot&&i*prm[j]<=maxn;j++)
        {
            have[i*prm[j]]=1;
            if (i%prm[j]==0) break;
        }
    }
    while (scanf("%d%d%d%d",&p,&q,&r,&s)==4)
    {
        for (i=1;i<=tot;i++)
          cnt[i]=0;
        add(p,1);
        add(q,-1);
        add(p-q,-1);
        add(r,-1);
        add(s,1);
        add(r-s,1);
        ans=1;
        for (i=1;i<=tot;i++)
          ans*=pow(prm[i],cnt[i]);
        printf("%.5f\n",ans);
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值