poj 3132 Sum of Different Primes

Sum of Different Primes
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 3465 Accepted: 2149
Description

A positive integer may be expressed as a sum of different prime numbers (primes), in one way or another. Given two positive integers n and k, you should count the number of ways to express n as a sum of k different primes. Here, two ways are considered to be the same if they sum up the same set of the primes. For example, 8 can be expressed as 3 + 5 and 5 + 3 but the are not distinguished.

When n and k are 24 and 3 respectively, the answer is two because there are two sets {2, 3, 19} and {2, 5, 17} whose sums are equal to 24. There are not other sets of three primes that sum up to 24. For n = 24 and k = 2, the answer is three, because there are three sets {5, 19}, {7, 17} and {11, 13}. For n = 2 and k = 1, the answer is one, because there is only one set {2} whose sum is 2. For n = 1 and k = 1, the answer is zero. As 1 is not a prime, you shouldn’t count {1}. For n = 4 and k = 2, the answer is zero, because there are no sets of two different primes whose sums are 4.

Your job is to write a program that reports the number of such ways for the given n and k.

Input

The input is a sequence of datasets followed by a line containing two zeros separated by a space. A dataset is a line containing two positive integers n and k separated by a space. You may assume that n ≤ 1120 and k ≤ 14.

Output

The output should be composed of lines, each corresponding to an input dataset. An output line should contain one non-negative integer indicating the number of the ways for n and k specified in the corresponding dataset. You may assume that it is less than 231.

Sample Input

24 3
24 2
2 1
1 1
4 2
18 3
17 1
17 3
17 4
100 5
1000 10
1120 14
0 0
Sample Output

2
3
1
0
0
2
1
0
1
55
200102899
2079324314


【分析】
素数筛法,01背包统计方案数。


【代码】

//poj 3132 Sum of Different Primes
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#define M(a) memset(a,0,sizeof a)
#define fo(i,j,k) for(i=j;i<=k;i++)
using namespace std;
const int mxn=1125;
int pri[mxn+1],vis[mxn+1],f[16][mxn+1];
int tot,n,k;
inline void shai()
{
    int i,j;
    fo(i,2,mxn)
    {
        if(!vis[i]) pri[++tot]=i;
        fo(j,1,tot)
        {
            if(i*pri[j]>=mxn) break;
            vis[i*pri[j]]=1;
            if(i%pri[j]==0) break;
        }
    }
}
int main()
{
    int i,j,p;
    shai();
    f[0][0]=1;
    fo(j,1,tot)
      for(p=1123;p>=pri[j];p--)
        fo(i,1,15)
          f[i][p]+=f[i-1][p-pri[j]];
    while(scanf("%d%d",&n,&k) && n && k)
      printf("%d\n",f[k][n]);
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值