洛谷 P3112 [USACO14DEC]后卫马克Guard Mark

题目描述

Farmer John and his herd are playing frisbee. Bessie throws the

frisbee down the field, but it’s going straight to Mark the field hand

on the other team! Mark has height H (1 <= H <= 1,000,000,000), but

there are N cows on Bessie’s team gathered around Mark (2 <= N <= 20).

They can only catch the frisbee if they can stack up to be at least as

high as Mark. Each of the N cows has a height, weight, and strength.

A cow’s strength indicates the maximum amount of total weight of the

cows that can be stacked above her.

Given these constraints, Bessie wants to know if it is possible for

her team to build a tall enough stack to catch the frisbee, and if so,

what is the maximum safety factor of such a stack. The safety factor

of a stack is the amount of weight that can be added to the top of the

stack without exceeding any cow’s strength.

FJ将飞盘抛向身高为H(1 <= H <= 1,000,000,000)的Mark,但是Mark

被N(2 <= N <= 20)头牛包围。牛们可以叠成一个牛塔,如果叠好后的高度大于或者等于Mark的高度,那牛们将抢到飞盘。

每头牛都一个身高,体重和耐力值三个指标。耐力指的是一头牛最大能承受的叠在他上方的牛的重量和。请计算牛们是否能够抢到飞盘。若是可以,请计算牛塔的最大稳定强度,稳定强度是指,在每头牛的耐力都可以承受的前提下,还能够在牛塔最上方添加的最大重量。

输入输出格式

输入格式:
INPUT: (file guard.in)

The first line of input contains N and H.

The next N lines of input each describe a cow, giving its height,

weight, and strength. All are positive integers at most 1 billion.

输出格式:
OUTPUT: (file guard.out)

If Bessie’s team can build a stack tall enough to catch the frisbee, please output the maximum achievable safety factor for such a stack.

Otherwise output “Mark is too tall” (without the quotes).

输入输出样例

输入样例#1:
4 10
9 4 1
3 3 5
5 5 10
4 4 5
输出样例#1:
2


【分析】
状压dp。稳。
dp[i]表示状态为i时的牛塔最大承受强度~


【代码】

//洛谷 P3112 [USACO14DEC] 后卫马克Guard Mark
#include<iostream>
#include<cstring>
#include<cstdio>
#define ll long long
#define M(a) memset(a,0,sizeof a)
#define fo(i,j,k) for(i=j;i<=k;i++)
using namespace std;
int n,m,ans=-1;
int h[25],w[25],t[25],tot[1<<20];
int change[1<<20];
int dp[1<<20];  //状态为i时牛塔所能承受的最大压力
inline void init()  //每种状态的总高度 
{
    int i,j,k,s,now,tmp;
    fo(i,0,n-1) change[1<<i]=i;
    fo(s,0,(1<<n)-1)
    {
        now=s;
        while(now)
        {
            tmp=now&-now;
            tot[s]+=h[change[tmp]];
            now-=tmp;
        }
    }
}
int main()
{
    int i,j,k,s;
    scanf("%d%d",&n,&m);
    fo(i,0,n-1) scanf("%d%d%d",&h[i],&w[i],&t[i]);
    s=0;
    init();
    dp[0]=1e9+1e9+7;  //没有牛时可视为能撑住无穷大的重量 
    fo(s,0,(1<<n)-1)
    {
        fo(i,0,n-1)
          if(!(s&(1<<i)))
          {
              dp[s|(1<<i)]=max(dp[s|(1<<i)],min(t[i],dp[s]-w[i]));
              if(tot[s|(1<<i)]>=m) ans=max(ans,dp[s|(1<<i)]);
          }
    }
    if(ans>0) printf("%d\n",ans);
    else printf("Mark is too tall\n");
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值