HDU1535 Invitation Cards(最短路)

Invitation Cards

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 3182    Accepted Submission(s): 1475


Problem Description
In the age of television, not many people attend theater performances. Antique Comedians of Malidinesia are aware of this fact. They want to propagate theater and, most of all, Antique Comedies. They have printed invitation cards with all the necessary information and with the programme. A lot of students were hired to distribute these invitations among the people. Each student volunteer has assigned exactly one bus stop and he or she stays there the whole day and gives invitation to people travelling by bus. A special course was taken where students learned how to influence people and what is the difference between influencing and robbery.
The transport system is very special: all lines are unidirectional and connect exactly two stops. Buses leave the originating stop with passangers each half an hour. After reaching the destination stop they return empty to the originating stop, where they wait until the next full half an hour, e.g. X:00 or X:30, where 'X' denotes the hour. The fee for transport between two stops is given by special tables and is payable on the spot. The lines are planned in such a way, that each round trip (i.e. a journey starting and finishing at the same stop) passes through a Central Checkpoint Stop (CCS) where each passenger has to pass a thorough check including body scan.

All the ACM student members leave the CCS each morning. Each volunteer is to move to one predetermined stop to invite passengers. There are as many volunteers as stops. At the end of the day, all students travel back to CCS. You are to write a computer program that helps ACM to minimize the amount of money to pay every day for the transport of their employees.

 

Input
The input consists of N cases. The first line of the input contains only positive integer N. Then follow the cases. Each case begins with a line containing exactly two integers P and Q, 1 <= P,Q <= 1000000. P is the number of stops including CCS and Q the number of bus lines. Then there are Q lines, each describing one bus line. Each of the lines contains exactly three numbers - the originating stop, the destination stop and the price. The CCS is designated by number 1. Prices are positive integers the sum of which is smaller than 1000000000. You can also assume it is always possible to get from any stop to any other stop.
 

Output
For each case, print one line containing the minimum amount of money to be paid each day by ACM for the travel costs of its volunteers.
 

Sample Input
  
  
2 2 2 1 2 13 2 1 33 4 6 1 2 10 2 1 60 1 3 20 3 4 10 2 4 5 4 1 50
 

Sample Output
  
  
46 210


图中的路径都是单向的,题目要求从起点(编号为1)到达其他的所有顶点,并且还要回到起点,问最小消耗。

简单的最短路,直接正反建立两个图,跑两遍Dijkstra;

#include<cstdio>
#include<algorithm>
#include<vector>
#include<iostream>
#include<cstring>
#include<queue>
#define INF 0x3f3f3f3f
using namespace std;
const int maxn = 1000000+10;
struct node{
    int v,len;
    node(int v= 0,int len = 0):v(v),len(len){};
    bool operator < (const node&a)const{
        return len> a.len;
    }
};
int n,m;
vector<node>G[maxn];
vector<node>G2[maxn];
int dis[maxn],vis[maxn];
void Dijkstra(vector<node>G[]){
    memset(vis,0,sizeof(vis));
    for(int i=0;i<=n;i++)dis[i] = INF;
    /*for(int i=0;i<G[1].size();i++){
        dis[i] = G[1][i].len;
    }*/ //这个地方的代码不能加上,因为这里更新的点,下面的队列中就不会添加这些点了。
    dis[1] = 0;
    priority_queue<node>Q;
    Q.push(node(1,0));
    while(!Q.empty()){
        node now = Q.top();Q.pop();
        int v = now.v;
        if(vis[v]) continue; vis[v] = 1;
        for(int i=0;i<G[v].size();i++){
            int u = G[v][i].v; int len = G[v][i].len;
            if(!vis[u] && dis[u] > dis[v] + len){
                dis[u] = dis[v] + len;
                Q.push(node(u,dis[u]));
            }
        }
    }
}
int main(){
    int T; scanf("%d",&T);
    while(T--){
         scanf("%d%d",&n,&m);
         int a,b,c;
        for(int i=0;i<=n;i++) G[i].clear(),G2[i].clear();
        for(int i=0;i<m;i++){
            scanf("%d%d%d",&a,&b,&c);
            G[a].push_back(node(b,c));// 正向建立图
            G2[b].push_back(node(a,c)); //反向建立图
        }
        int ans = 0;
        Dijkstra(G);
        for(int i=1;i<=n;i++)
            ans+= dis[i];
        Dijkstra(G2);
        for(int i=1;i<=n;i++)
            ans+= dis[i];
        printf("%d\n",ans);
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值