【POJ 3352】 Road Construction(边联通分量入门)

【POJ 3352】 Road Construction(边联通分量入门)


Road Construction
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 10418 Accepted: 5164

Description

It's almost summer time, and that means that it's almost summer construction time! This year, the good people who are in charge of the roads on the tropical island paradise of Remote Island would like to repair and upgrade the various roads that lead between the various tourist attractions on the island.

The roads themselves are also rather interesting. Due to the strange customs of the island, the roads are arranged so that they never meet at intersections, but rather pass over or under each other using bridges and tunnels. In this way, each road runs between two specific tourist attractions, so that the tourists do not become irreparably lost.

Unfortunately, given the nature of the repairs and upgrades needed on each road, when the construction company works on a particular road, it is unusable in either direction. This could cause a problem if it becomes impossible to travel between two tourist attractions, even if the construction company works on only one road at any particular time.

So, the Road Department of Remote Island has decided to call upon your consulting services to help remedy this problem. It has been decided that new roads will have to be built between the various attractions in such a way that in the final configuration, if any one road is undergoing construction, it would still be possible to travel between any two tourist attractions using the remaining roads. Your task is to find the minimum number of new roads necessary.

Input

The first line of input will consist of positive integers n and r, separated by a space, where 3 ≤n ≤ 1000 is the number of tourist attractions on the island, and 2 ≤ r ≤ 1000 is the number of roads. The tourist attractions are conveniently labelled from 1 ton. Each of the following r lines will consist of two integers, v and w, separated by a space, indicating that a road exists between the attractions labelledv and w. Note that you may travel in either direction down each road, and any pair of tourist attractions will have at most one road directly between them. Also, you are assured that in the current configuration, it is possible to travel between any two tourist attractions.

Output

One line, consisting of an integer, which gives the minimum number of roads that we need to add.

Sample Input

Sample Input 1
10 12
1 2
1 3
1 4
2 5
2 6
5 6
3 7
3 8
7 8
4 9
4 10
9 10

Sample Input 2
3 3
1 2
2 3
1 3

Sample Output

Output for Sample Input 1
2

Output for Sample Input 2
0

Source


题目大意:有n个旅游景点 r条路线,每条路线双向链接两个景区

由于每条线路都有可能被施工,并且保证每次施工只对一条线路进行。问至少需要添加几条边,能保证不论那条边在修建时,城市始终还是连通的


首先修建会影响连通性的边,就是图的桥。这样用tarjan求出桥后,可把边连通分量进行缩点。然后缩点后出度为1的点是必要加边的点。

这样出度为1的点数leaf (leaf+1)/2即可求出最少加边数


代码如下:

#include <iostream>
#include <cmath>
#include <vector>
#include <cstdlib>
#include <cstdio>
#include <cstring>
#include <queue>
#include <stack>
#include <list>
#include <algorithm>
#include <map>
#include <set>
#define LL long long
#define Pr pair<int,int>
#define fread() freopen("in.in","r",stdin)
#define fwrite() freopen("out.out","w",stdout)

using namespace std;
const int INF = 0x3f3f3f3f;
const int msz = 10000;
const int mod = 1e9+7;
const double eps = 1e-8;

struct Edge
{
	int v,next;
};

int head[1111];
Edge eg[2333];
int n,r;

int dfn[1111],low[1111];
int in[1111];
int vis[1111];
int tim;

void tarjan(int u,int pre)
{
	vis[u] = 1;
	dfn[u] = low[u] = tim++;

	int v;
	for(int i = head[u]; i != -1; i = eg[i].next)
	{
		v = eg[i].v;
		if(v == pre) continue;
		if(!vis[v])
		{
			tarjan(v,u);
			low[u] = min(low[u],low[v]);
		}
		else low[u] = min(low[u],dfn[v]);
	}
}

void init()
{
	memset(head,-1,sizeof(head));
	memset(vis,0,sizeof(vis));
	tim = 0;
}

int main()
{
	//fread();
	//fwrite();

	int u,v;
	while(~scanf("%d%d",&n,&r))
	{
		init();
		for(int i = 0; i < r; ++i)
		{
			scanf("%d%d",&u,&v);
			eg[i<<1].v = v;
			eg[i<<1].next = head[u];
			head[u] = i<<1;

			eg[i<<1|1].v = u;
			eg[i<<1|1].next = head[v];
			head[v] = i<<1|1;
		}

		tarjan(1,1);

		int ans = 0;
		memset(in,0,sizeof(in));

		for(int i = 1; i <= n; ++i)
			for(int j = head[i]; j != -1; j = eg[j].next)
			{
				if(low[i] != low[eg[j].v]) in[low[i]]++;
			}

		for(int i = 0; i < n; ++i)
		{
			if(in[i] == 1) ans++;
		}
		printf("%d\n",(ans+1)>>1);
	}

	return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值