Catch That Cow
Time Limit: 2000ms Memory limit: 65536K 有疑问?点这里^_^
题目描述
Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting. * Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute * Teleporting: FJ can move from any point X to the point 2 × X in a single minute. If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?
输入
Line 1: Two space-separated integers: N and K
输出
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
示例输入
5 17
示例输出
4
提示
poj3278 有链接提示的题目请先去链接处提交程序,AC后提交到SDUTOJ中,以便查询存档。
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.
来源
广度优先搜索练习
#include<bits/stdc++.h>
using namespace std;
#define M 100001
int n,k;
bool vist[M];
struct node
{
int n,step;
}now,next;
queue<node> q;
int bfs()
{
now.n=n;
now.step=0;
q.push(now);
vist[now.n]=true;
while (!q.empty())
{
now=q.front();
q.pop();
for (int i=0;i<3;i++)
{
if (i==0)
next.n=now.n+1;
if (i==1)
next.n=now.n-1;
if (i==2)
next.n=now.n*2;
next.step=now.step+1;
if (next.n==k)
return next.step;
if (next.n<0||next.n>M)
continue;
if (!vist[next.n])
{
vist[next.n]=true;
q.push(next);
}
}
}
}
int main()
{
cin>>n>>k;
if (n==k)
cout<<0<<endl;
if (n<k)
cout<<bfs()<<endl;
if (n>k)
cout<<n-k<<endl;
return 0;
}