Catch That Cow

Catch That Cow

Time Limit: 2000ms   Memory limit: 65536K  有疑问?点这里^_^

题目描述

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting. * Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute * Teleporting: FJ can move from any point X to the point 2 × X in a single minute. If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

输入

Line 1: Two space-separated integers: N and K

输出

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

示例输入

5 17

示例输出

4

提示

poj3278 有链接提示的题目请先去链接处提交程序,AC后提交到SDUTOJ中,以便查询存档。
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

来源

广度优先搜索练习


#include<bits/stdc++.h>

using namespace std;

#define    M   100001

int n,k;
bool vist[M];
struct node
{
       int n,step;
}now,next;
queue<node> q;

int bfs()
{
         now.n=n;
         now.step=0;
         q.push(now);
         vist[now.n]=true;
         while (!q.empty())
         {
                 now=q.front();
                 q.pop();
                 for (int i=0;i<3;i++)
                 {
                        if (i==0)
                        next.n=now.n+1;
                        if (i==1)
                        next.n=now.n-1;
                        if (i==2)
                        next.n=now.n*2;
                        next.step=now.step+1;
                        if (next.n==k)
                        return next.step;
                        if (next.n<0||next.n>M)
                        continue;
                        if (!vist[next.n])
                        {
                              vist[next.n]=true;
                              q.push(next);
                        }
                 }
         }
}

int main()
{
      cin>>n>>k;
      if (n==k)
      cout<<0<<endl;
      if (n<k)
      cout<<bfs()<<endl;
      if (n>k)
      cout<<n-k<<endl;
      return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值