PAT甲级 1047. Student List for Course (25)

题目:

Zhejiang University has 40000 students and provides 2500 courses. Now given the registered course list of each student, you are supposed to output the student name lists of all the courses.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (<=40000), the total number of students, and K (<=2500), the total number of courses. Then N lines follow, each contains a student's name (3 capital English letters plus a one-digit number), a positive number C (<=20) which is the number of courses that this student has registered, and then followed by C course numbers. For the sake of simplicity, the courses are numbered from 1 to K.

Output Specification:

For each test case, print the student name lists of all the courses in increasing order of the course numbers. For each course, first print in one line the course number and the number of registered students, separated by a space. Then output the students' names in alphabetical order. Each name occupies a line.

Sample Input:
10 5
ZOE1 2 4 5
ANN0 3 5 2 1
BOB5 5 3 4 2 1 5
JOE4 1 2
JAY9 4 1 2 5 4
FRA8 3 4 2 5
DON2 2 4 5
AMY7 1 5
KAT3 3 5 4 2
LOR6 4 2 4 1 5
Sample Output:
1 4
ANN0
BOB5
JAY9
LOR6
2 7
ANN0
BOB5
FRA8
JAY9
JOE4
KAT3
LOR6
3 1
BOB5
4 7
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1
5 9
AMY7
ANN0
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1
思路:

与39题很像,但不需要将字符串转化。在输入时,把学生输入到相应课程名下,排序之后输出就可以了。但是仍有一个测试点未通过,应该是cin和cout的问题。这里要注意的是,用printf输出字符串会报错:cannot pass objects of non-trivially-copyable type。。。解决方案是加上c_str(),例如printf("%s\n",C[i].name[j].c_str());

代码:

#include<iostream>
#include<vector>
#include<string>
#include<algorithm>
using namespace std;

struct course
{
	int id;
	vector<string> name;
};

int main()
{

	int N, K;
	cin >> N >> K;

	vector<course> C(K + 1);
	int i, j, k, num;
	for (i = 1; i <= K; ++i)
	{
		C[i].id = i;
	}

	string name;
	for (i = 0; i < N; ++i)
	{
		cin >> name >> num;
		for (j = 0; j < num; ++j)
		{
			scanf("%d",&k);
			C[k].name.push_back(name);
		}
	}

	for (i = 1; i <= K; ++i)
	{
		printf("%d %d\n",i,C[i].name.size());
		sort(C[i].name.begin(), C[i].name.end());
		for (j = 0; j < C[i].name.size(); ++j)
		{
			printf("%s\n",C[i].name[j].c_str());
		}
	}
	system("pause");
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值