【PAT】1047. Student List for Course (25)【优先队列的使用】

题目描述

Zhejiang University has 40000 students and provides 2500 courses. Now given the registered course list of each student, you are supposed to output the student name lists of all the courses.

翻译:浙江大学有40000个学生,提供2500种课程。现在给你每个学生的课程登记表,你需要输出所有课程的学生名单。

INPUT FORMAT

Each input file contains one test case. For each case, the first line contains 2 numbers: N (<=40000), the total number of students, and K (<=2500), the total number of courses. Then N lines follow, each contains a student’s name (3 capital English letters plus a one-digit number), a positive number C (<=20) which is the number of courses that this student has registered, and then followed by C course numbers. For the sake of simplicity, the courses are numbered from 1 to K.

翻译:每个输入文件包含一组测试数据。对于每组输入数据,第一行包括2个数字:N (<=40000)代表学生总数,和K (<=2500)代表总课程数。接着N行,每行包括一个学生的名字(3个英文字符加一个数字),一个正整数C (<=20) 代表学生登记课程的数量,接着是C个课程编号。为了简单起见,课程被标记为1到K。

OUTPUT FORMAT

For each test case, print the student name lists of all the courses in increasing order of the course numbers. For each course, first print in one line the course number and the number of registered students, separated by a space. Then output the students’ names in alphabetical order. Each name occupies a line.

翻译:对于每组输入数据,按照登记的学生姓名升序输出该课程登记的学生姓名表。对于每个课程,首先输出一行课程编号和登记的学生数量,用空格隔开。接着按照字母序输出学生的姓名。每个姓名占一行。


Sample Input:

10 5
ZOE1 2 4 5
ANN0 3 5 2 1
BOB5 5 3 4 2 1 5
JOE4 1 2
JAY9 4 1 2 5 4
FRA8 3 4 2 5
DON2 2 4 5
AMY7 1 5
KAT3 3 5 4 2
LOR6 4 2 4 1 5

Sample Output:

1 4
ANN0
BOB5
JAY9
LOR6
2 7
ANN0
BOB5
FRA8
JAY9
JOE4
KAT3
LOR6
3 1
BOB5
4 7
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1
5 9
AMY7
ANN0
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1


解题思路

这道题跟之前一样,用string会超时,所以就转换为数字进行操作(其实用char数组strcmp函数比较感觉更快,不过之前代码都有,就懒得打了:)。最近用priority_queue用上瘾了,所有需要排序的题一律优先队列。。。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<string>
#include<vector>
#include<queue>
#include<map>
#include<algorithm>
#define INF 99999999
using namespace std;
priority_queue<int,vector<int>,greater<int> >p[2510];
int N,K;
int Change(char a[]){
    long long int Sum=0;
    for(int i=0;i<3;i++){
        Sum=Sum*26+(a[i]-'A');
    }
    Sum=Sum*10;
    Sum+=(a[3]-'0');
    return Sum;
}
void Print(int a){
    char temp[4];
    temp[3]=a%10;a/=10;
    for(int i=2;i>=0;i--){
        temp[i]=a%26;a/=26;
    }
    for(int i=0;i<4;i++){
        if(i==3)printf("%c",temp[i]+'0');
        else printf("%c",temp[i]+'A');
    }
    printf("\n");
}
int main(){
    scanf("%d%d",&N,&K);
    int M;
    char s[5];
    for(int i=0;i<N;i++){
        scanf("%s%d",s,&M);
        int temp=Change(s);
        int a;
        for(int j=0;j<M;j++){
            scanf("%d",&a);
            p[a].push(temp);
        }
    }
    for(int i=1;i<=K;i++){
        printf("%d %d\n",i,p[i].size());
        while(!p[i].empty()){
            int temp=p[i].top();p[i].pop();
            Print(temp);
        }
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值