HDU 1385-Minimum Transport Cost(floyd&&最小字典序)

address : http://acm.hdu.edu.cn/showproblem.php?pid=1385

Problem Description
These are N cities in Spring country. Between each pair of cities there may be one transportation track or none. Now there is some cargo that should be delivered from one city to another. The transportation fee consists of two parts:
The cost of the transportation on the path between these cities, and

a certain tax which will be charged whenever any cargo passing through one city, except for the source and the destination cities.

You must write a program to find the route which has the minimum cost.

Input
First is N, number of cities. N = 0 indicates the end of input.

The data of path cost, city tax, source and destination cities are given in the input, which is of the form:

a11 a12 … a1N
a21 a22 … a2N
……………
aN1 aN2 … aNN
b1 b2 … bN

c d
e f

g h

where aij is the transport cost from city i to city j, aij = -1 indicates there is no direct path between city i and city j. bi represents the tax of passing through city i. And the cargo is to be delivered from city c to city d, city e to city f, …, and g = h = -1. You must output the sequence of cities passed by and the total cost which is of the form:

Output
From c to d :
Path: c–>c1–>……–>ck–>d
Total cost : ……
……

From e to f :
Path: e–>e1–>……….–>ek–>f
Total cost : ……

Note: if there are more minimal paths, output the lexically smallest one. Print a blank line after each test case.

Sample Input
5
0 3 22 -1 4
3 0 5 -1 -1
22 5 0 9 20
-1 -1 9 0 4
4 -1 20 4 0
5 17 8 3 1
1 3
3 5
2 4
-1 -1
0

Sample Output
From 1 to 3 :
Path: 1–>5–>4–>3
Total cost : 21

From 3 to 5 :
Path: 3–>4–>5
Total cost : 16

From 2 to 4 :
Path: 2–>1–>5–>4
Total cost : 17

题解不写了 ,需要注意的 都在代码注释里, 其实只需要注意路径的变化
和寻找最小字典序路径

code:

#include <iostream>
#include <bits/stdc++.h>
using namespace std;
const int INF=99999999;
int Map[1202][1202];
int cost[1202];
int path[1202][1202];
int N;
void floyd()
{
    int i,j,k;
    for(k=1; k<=N; k++)
        for(i=1; i<=N; i++)
            for(j=1; j<=N; j++)
            {
                //因为经过中间点需要付过路费,所以加上
                if(Map[i][j]>Map[i][k]+Map[k][j]+cost[k])
                {
                    Map[i][j]=Map[i][k]+Map[k][j]+cost[k];
                    path[i][j]=path[i][k];   //保存当前可到达点的前驱点 下次找从k开始的路径
                    //cout<<path[i][j]<<endl;
                }
                else if(Map[i][j]==Map[i][k]+Map[k][j]+cost[k])//寻找字典序更小的路径
                {
                    if(path[i][j]>path[i][k])
                    {
                        path[i][j]=path[i][k];
                    }
                }
            }
}
int main()
{
    while (scanf("%d",&N),N!=0)
    {
        memset(Map, 0, sizeof(Map));
         memset(cost, 0, sizeof(cost));
        for (int i=1; i<=N; i++)
        {
            for (int j=1; j<=N; j++)
            {
                path[i][j]=j;   //初始化路径,想让2点可以直达,那么j为终点
                scanf("%d",&Map[i][j]);
                if (Map[i][j]==-1)
                    Map[i][j] = INF;
            }
        }
        for (int i=1; i<=N; i++)
        {
            scanf("%d",&cost[i]);
        }
        floyd();

        int be, en;
        while (scanf("%d%d",&be,&en))
        {
            if (be==-1&&en==-1)
                break;
             printf("From %d to %d :\n",be,en);
            printf("Path: %d",be);
            int u=be,v=en;
            while (u!=v)  //不断往后找
            {
                printf ("-->%d", path[u][v]);
                u=path[u][v];
            }
            printf("\n");
            printf("Total cost : %d\n\n",Map[be][en]);
        }

    }
        return 0;
    }
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值