南邮 OJ 1124 Hotel

Hotel

时间限制(普通/Java) :  2000 MS/ 6000 MS          运行内存限制 : 65536 KByte
总提交 : 75            测试通过 : 15 

比赛描述

Last year summer Max traveled to California for his vacation. He had a great time there: took many photos, visited famous universities, enjoyed beautiful beaches and tasted various delicious foods. It is such a good trip that Max plans to traveled there one more time this year. Maxis satisfied with the accommodation of the hotel he booked last year but he lost the card of that hotel and can not remember quite clearly what its name is. So Max searched in the web for the information of hotels in California and got piles of choices. Could you help Max pick out those that might be the right hotel?



输入

 Input may consist of several test data sets. For each data set, it can be format as below:
 For the first line, there is one string consisting of ‘*’, ‘?’ and ’a’-‘z’ characters. This string represents the hotel name that Max can remember. The ‘*’ and ’?’ is wildcard characters. ‘*’ matches zero or more lowercase character(s), and ‘?’ matches only one lowercase character.
 In the next line there is one integer n (1<=n<=10000) representing the number of hotel Max found, and then n lines follow. Each line contains one string of lowercase character(s), the name of the hotel.
 The length of every string doesn’t exceed 50.

输出

 For each test data set, just simply output one integer in a line telling the number of hotel in the list whose name matches the one Max remembered.

样例输入

herbert
2
amazon
herbert
?ert*
2
amazon
hertert
*
2
amazon
anything
hertber?
2
amazon
herber

样例输出

1
1
2
0

题目来源

第九届中山大学程序设计竞赛预选题




#include<stdio.h>

bool match(char *a, char *b){
	if('\0'==*a && '\0'==*b){
		return 1;
	}
	if('\0'==*a && *b!='\0' || '\0'!=*a && *b=='\0'){
		return 0;
	}
	if('?'==*a || *a==*b){
		return match(a+1, b+1);
	}
	if('*'==*a){
		a++;
		if(match(a, b)){
			return 1;
		}
		while(*b!='\0'){
			b++;
			if(match(a,b)){
				return 1;
			}
		}
	}
	return 0;
}

int main(){
	char a[51],b[51];
	int N,sum;
	while(scanf("%s",a)==1){
		scanf("%d",&N);
		sum = 0;
		while(N--){
			scanf("%s",b);
			if(match(a,b)){
				sum++;
			}
		}
		printf("%d\n",sum);
	}
}






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值