南邮 OJ 1531 A ? Sixth Grade Math

A ? Sixth Grade Math

时间限制(普通/Java) :  1000 MS/ 3000 MS          运行内存限制 : 65536 KByte
总提交 : 27            测试通过 : 27 

比赛描述

In sixth grade, students are presented with different ways to calculate the Least Common Multiple(LCM) and the Greatest Common Factor (GCF) of two integers. The LCM of two integers and isthe smallest positive integer that is a multiple of both and b. The GCF of two non-zero integers aand is the largest positive integer that divides both and without remainder.For this problem you will write a program that determines both the LCM and GCF for positiveintegers.



输入

The first line of input contains a single integer N, (1 £ £ 1000) which is the number of data sets thatfollow. Each data set consists of a single line of input containing two positive integers, and b,(1 £ a,b £ 1000) separated by a space.

输出

For each data set, you should generate one line of output with the following values: The data setnumber as a decimal integer (start counting at one), a space, the LCM, a space, and theGCF.

样例输入

3
5 10
7 23
42 56

样例输出

1 10 5
2 161 1
3 168 14

提示

undefined

题目来源

ACM ICPC Greater New York Region 2008





#include<stdio.h>
int main(){
	int n,i,a,b,temp;
	scanf("%d",&n);
	for(i=1; i<=n; i++){
		scanf("%d%d",&a,&b);
		temp = a*b;
		if(a<b){
			a ^= b;
			b ^= a;
			a ^= b;
		}
		while(a%b){
			a = a%b;
			a ^= b;
			b ^= a;
			a ^= b;
		}
		printf("%d %d %d\n",i,temp/b,b);
	}
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值