nyoj-412-Same binary weight(位运算)

Same binary weight

时间限制: 300 ms  |  内存限制: 65535 KB
难度: 3
描述

The binary weight of a positive  integer is the number of 1's in its binary representation.for example,the decmial number 1 has a binary weight of 1,and the decimal number 1717 (which is 11010110101 in binary) has a binary weight of 7.Give a positive integer N,return the smallest integer greater than N that has the same binary weight as N.N will be between 1 and 1000000000,inclusive,the result is guaranteed to fit in a signed 32-bit interget.

输入
The input has multicases and each case contains a integer N.
输出
For each case,output the smallest integer greater than N that has the same binary weight as N.
样例输入
1717
4
7
12
555555
样例输出
1718
8
11
17
555557
来源
topcoder
上传者
骆魁永


 

/*分析:把n转换成二进制,找到第一个为 1 的位置p1(x&-x),
从该位置开始再找第一个为 0 的位置p2,统计从p1位置到p2位置
 1 的个数 c,然后把位置p2的0转换为1,最后把c-1个 1 加到最低位。
*/

#include<iostream>
#include<cstdio>
#include<cmath>
using namespace std;
int main()
{
    int n;
    while(cin>>n)
    {
        int t,t1,t2;
        t=n;
        int tt=n&-n;
        if(t==tt)  //为1的时候 
        {
            n=n<<1;
            cout<<n<<endl;
	   continue;
        }
        int c=0,s=0;
        while(t)
        {
            t1=t&-t;//找到并截取第一个1及其后面0构成的十进制数赋给t1 
            t=t-t1;
            t2=t&-t;
            c++;s+=t1;
            if(t2>2*t1)//找0的位置,或者说找不在一起的1(即11(2进制)), 应该找101,1001,100001.。。。。而非1111类型的 
            {
                t1=t1<<1;
                n = n-s+t1+pow(2,c-1)-1;
                break;
            }
        }
        if(t==0)//没找到0,即第一个1(地位算起)向高位中没有找到0,就像111111,11111000, 
		  n=(t1<<1)+pow(2,c-1)-1;
        cout<<n<<endl;
    }
    return 0;
}


 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值