Same binary weight

Same binary weight

时间限制: 300 ms  |  内存限制: 65535 KB
难度: 3
描述

The binary weight of a positive  integer is the number of 1's in its binary representation.for example,the decmial number 1 has a binary weight of 1,and the decimal number 1717 (which is 11010110101 in binary) has a binary weight of 7.Give a positive integer N,return the smallest integer greater than N that has the same binary weight as N.N will be between 1 and 1000000000,inclusive,the result is guaranteed to fit in a signed 32-bit interget.

输入
The input has multicases and each case contains a integer N.
输出
For each case,output the smallest integer greater than N that has the same binary weight as N.
样例输入
1717
4
7
12
555555
样例输出
1718
8
11
17
555557
来源
topcoder
上传者

骆魁永

参考思想网址:http://www.cnblogs.com/yewei/archive/2012/09/21/2696499.html

参考代码:讨论区里

刚开始做的超时了。现在知道一个方法就是把数对应的二进制位,从右往左,找到第一个“01” 变为“10”,然后此“01”串后面的‘1’都放到后面。

我看到其他博客写的按位运算,我看不懂,水平还太次。看到讨论区里的一个大神的代码,第一次接触了.#include<bitset> 感觉这个库文件好棒。

#include <iostream>//<span style="color: rgb(113, 32, 21); font-family: Tahoma, Arial, sans-serif, simsun; font-size: 16px; "><strong>超时代码:</strong></span>
#include<bitset>
#include<string>
#include<stdio.h>
#include<algorithm>
using namespace std;
int main()
{
	int n;
     while(scanf("%d",&n)!=EOF)
	 {
	 bitset<32> bitint(n);
         string s=bitint.to_string();
         int pos=s.rfind("01");
         swap(s[pos],s[pos+1]);
         if(pos+2<31) 
	     sort(s.begin()+pos+2,s.end());
       cout<<bitset<32>(s).to_ulong()<<endl;
	 }
	return 0;
}



#include<iostream>
#include<stdio.h>
using namespace std;
int diaoyong(int n)
{ 
    int k=0;
	int count=0;
	while(n!=0)
	{
	   if(n%2==1)
		  count++;
		n=n/2;
	}	
	return count;
}
int main()
{
	int n,count;
	while(scanf("%d",&n)!=EOF)
	{
		count=diaoyong(n);
	   while(++n)
	   {
		   if(count==diaoyong(n))
		   {
			   cout<<n<<endl;
			   break;
		   }     
	   }
	}
	return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值