2011.计算机院.Problem A.反转单词

题目描述
给出一句英文句子(只由大小写字母和空格组成,不含标点符号,也不会出现连续的空格),请将其中的所有单词顺序翻转

输入格式
多组数据,以EOF结束。
每行一句英文句子(确保只由大小写字母和空格组成,不含标点符号,也不会出现连续的空格,字符串总长度1000以内)

输出格式
每组数据输出一行,为反转后的字符串

输入样例

It is a apple

输出样例

apple a is It
#include<bits/stdc++.h>
using namespace std;
int main() {
	stack<string> str;
	string s;
	char c;
	while(cin>>s) {
		str.push(s);
		c=getchar();//空格或者换行
		if(c=='\n') {
			cout << str.top() << endl;
			str.pop();
		} else {
			while(cin>>s) {
				str.push(s);
				c=getchar();
				if(c=='\n') {
					break;
				}
			}
			cout << str.top();
			str.pop();
			while(!str.empty()) {
				cout << " "<<str.top();
				str.pop();
			}
			cout<<endl; 
		}
	}
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值