A + B Problem II(大数基础加法)

Description
I have a VERY SIMPLE problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
正整数高精度1000位加法
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
Output
For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line is the an equation “A + B = Sum”, Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
Sample Input

2
1 2
112233445566778899 998877665544332211
Sample Output

Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

题意:基础的大数的加法,将两个数都以字符数组的形式逐一相加,大于10就对10取余然后前一位加1

代码(C)

#include<stdio.h>
#include<string.h>
int main()
{
    int t,m,n,a[1010],b[1010],len1,len2;
    char str1[1010],str2[1010];
    scanf("%d",&n);
    for(int i=1;i<=n;i++)
    {
        memset(a,0,sizeof(a));  
        memset(b,0,sizeof(b));
        scanf("%s%s",str1,str2);
        len1=strlen(str1);
        len2=strlen(str2);
        for(int k=0;k<len1;k++)  //将字符串存入数组里计算
           a[len1-1-k]=str1[k]-'0';  
        for(int k=0;k<len2;k++)  
           b[len2-1-k]=str2[k]-'0'; 
        if(len1<=len2)  //比较大小后方便得出和的位数
        {
            t=len1;
            len1=len2;
            len2=t;
        }
        for(int j=0;j<len1;j++)
        {
            a[j]=a[j]+b[j];
            if(a[j]>9)
            {
                a[j]=a[j]%10;
                a[j+1]++;
            }
        }
        printf("Case %d:\n",i);
        printf("%s + %s = ",str1,str2);
        if(a[len1]==0)  //如果两个数相加后并没有进位
        {
            for(int j=len1-1;j>=0;j--)  printf("%d",a[j]);
            printf("\n");
        }
        else
        {
            for(int j=len1;j>=0;j--)  printf("%d",a[j]);
            printf("\n");
        }
        if(i!=n)  printf("\n");
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值